Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418222 - [Client Registration] client is not getting Registered due to transaction aborted error
Summary: [Client Registration] client is not getting Registered due to transaction abo...
Keywords:
Status: CLOSED DUPLICATE of bug 1405085
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Subscription Management
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 10:15 UTC by Jitendra Yejare
Modified: 2017-02-02 15:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 15:00:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
rhsm logs on Client (16.91 KB, text/plain)
2017-02-01 10:15 UTC, Jitendra Yejare
no flags Details

Description Jitendra Yejare 2017-02-01 10:15:59 UTC
Created attachment 1246602 [details]
rhsm logs on Client

Description of problem:

I am trying to register a number of clients in a loop to satellite host. The clients are based on Docker containers.
While registering these clients, I see some of the clients are not getting registered and throwing below error:
'ERROR:  current transaction is aborted, commands ignored until end of transaction block' with the tracebacks

Version-Release number of selected component (if applicable):
Satellite 6.2.6

How reproducible:
Always

Steps to Reproduce:
1. Register clients one after another in loop to satellite

Actual results:
Some clients are getting registered but few of them are not getting registered(depending on the volume of clients) and throwing transaction aborted error

Expected results:
The client(s) should get registered to satellite


Logs:
Attaching rhsm logs from the client.

Comment 3 jcallaha 2017-02-02 15:00:39 UTC

*** This bug has been marked as a duplicate of bug 1405085 ***


Note You need to log in before you can comment on or make changes to this bug.