Bug 1418226 - [RFE] OpenStack logging to have an option to include Region and Availability Zone info in logs
Summary: [RFE] OpenStack logging to have an option to include Region and Availability ...
Keywords:
Status: CLOSED DUPLICATE of bug 1454793
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: fluentd
Version: unspecified
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Lars Kellogg-Stedman
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 10:28 UTC by Miguel Perez Colino
Modified: 2019-09-09 15:35 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-20 05:51:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miguel Perez Colino 2017-02-01 10:28:37 UTC
Proposed title of this feature request

1. [RFE] OpenStack logging to have an option to include Region and Availability Zone info in logs

2. Who is behind the request?
Integrated Solutions Business Unit
Strategic Design Practice

3. What is the nature and description of the request?
To perform Openstack Operations, due to the distributed nature of the services that compose the OpenStack deployments, aggregated logging can provide a way to reduce time to perform troubleshooting, find root cause of issues, and have better insight on the health status of the Platform.
Being able to discriminate, in the logs, what's the Region and Availability Zona that a log belongs to enables better correlation and provides a more comprehensive view on multisite deployments

4. Why does the customer need this? (List the business requirements here)
- To have a better understanding on health status of the platform, filtered by Regions and Availability Zones
- To reduce the time troubleshooting issues
- To find and apply workarounds faster to the issues that may arise.

5. How would the customer like to achieve this? (List the functional requirements here)
- Having a configuration option to enable adding this info to logs
- To have this option enabled whenever Regions or Availability Zones are specified

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
- Check that the option is enabled
- Check OpenStack logs and verify that there are fields for region and availability zone with the name of them (i.e. region=brazil1 az=az2)

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
No

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
OSP12

9. Is the sales team involved in this request and do they have any additional input?
No

10. List any affected packages or components.
Nova
Keystone
Glance 
Cinder
Neutron

11. Would the customer be able to assist in testing this functionality if implemented?
Yes, depending on availability.

Comment 1 Rich Megginson 2017-02-04 00:28:18 UTC
Well, I'd like to cc Lars KS with this bz, but I can't figure out what his bz id is.

Lars, this should be added to the openstack data model for viaq.  Even though it may not be part of the data in each log event, it could be added to the record in fluentd.

Comment 2 Rich Megginson 2017-03-23 14:59:50 UTC
https://github.com/ViaQ/elasticsearch-templates/pull/30
adding openstack metadata - for common data model

Comment 3 Martin Magr 2017-04-21 09:09:11 UTC
Seems like Lars is working on this already, assigning the BZ to him.

Comment 4 Juan Badia Payno 2017-10-20 05:51:33 UTC

*** This bug has been marked as a duplicate of bug 1454793 ***


Note You need to log in before you can comment on or make changes to this bug.