Bug 1418246 - unable to monitor ActiveMQ
Summary: unable to monitor ActiveMQ
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.3.8
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: One-off release
Assignee: Simeon Pinder
QA Contact: Prachi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 11:27 UTC by Prachi
Modified: 2018-07-24 15:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-06 15:32:36 UTC
Type: Bug


Attachments (Terms of Use)
ActiveMQ process image (221.37 KB, image/png)
2017-02-01 11:27 UTC, Prachi
no flags Details
JON UI error (109.90 KB, image/png)
2017-02-01 11:29 UTC, Prachi
no flags Details
Adding agent (agent.log) logs (398.63 KB, text/plain)
2017-02-01 11:30 UTC, Prachi
no flags Details

Description Prachi 2017-02-01 11:27:36 UTC
Created attachment 1246610 [details]
ActiveMQ process image

Description of problem: Not able to monitor ActiveMQ


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Edit jboss-a-mq-6.2.1.redhat-159/etc/users.properties to add admin user:
   
   "admin=admin,admin,manager,viewer,Operator, Maintainer, Deployer, Auditor, Administrator, SuperUser"

2.navigate to Jboss Fuse container >> Inventory >> Connection Settings


3.edit Principal and Credentials as admin, admin.


Actual results:

After these settings JON should display ActiveMQ available as Active MQ is running successfully(attached screen-shot "activemq.png"). However, it is not showing any error in server.log of JON or agent.log of agent but in JON UI it shows error(attached screen-shot error.png).

Expected results:
JON should monitor ActiveMQ

Additional info:

Comment 1 Prachi 2017-02-01 11:29:08 UTC
Created attachment 1246611 [details]
JON UI error

Comment 2 Prachi 2017-02-01 11:30:55 UTC
Created attachment 1246613 [details]
Adding agent (agent.log) logs

Comment 3 Vojta Prusa 2017-03-09 20:43:01 UTC
Rerun with new Fuse Fabric Groups Plugin,

got same errors even after applying patch JON 3.3.8 ER02 and using Fuse Fabric Groups Plugin:
Name:	FabricGroupsPlugin
Version: 7.3.1.redhat-379
AMPS Version:	2.0
Kind: Server - MD5: 57829eeec13bdb02ce08bc58b0e34ff5
Kind: Agent - MD5: 88d713f213ef51519367e8d710eac8a8
Description:	Plugin to create and manage DynaGroups for Fabric Profiles.
Path:	fabric-groups-plugin-7.3.1.redhat-379.jar
Last Updated:	Mar 8, 2017 5:55:25 PM

Reproduce steps:
Following https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_A-MQ/6.2/html/Installation_Guide/instalJONplugin.html
and to get AMQ following https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_A-MQ/6.2/html/Installation_Guide/AMQInstallClients-JMSClients.html 

still getting:

org.rhq.core.clientapi.agent.PluginContainerException: Could not build component for Resource [Resource[id=10467, uuid=2aba853c-32a4-4776-b4ee-55b037e2b088, type={JBossFuse}JBoss Fuse Container, key=JBoss Fuse Container{/home/hudson/jboss-a-mq-6.2.1.redhat-084}, name=JBoss Fuse Container [root]{/home/hudson/jboss-a-mq-6.2.1.redhat-084} JBoss Fuse Container [root], parent=vprusa-jon-amq.bc.jonqe.lab.eng.bos.redhat.com, version=1.2.0.redhat-621084]]
	at org.rhq.core.pc.inventory.InventoryManager.prepareResourceForActivation(InventoryManager.java:2163)
	at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:2239)
	at org.rhq.core.pc.inventory.InventoryManager.activateAndUpgradeResourceRecursively(InventoryManager.java:3741)
	at org.rhq.core.pc.inventory.InventoryManager.activateAndUpgradeResourceRecursively(InventoryManager.java:3743)
	at org.rhq.core.pc.inventory.InventoryManager.activateAndUpgradeResources(InventoryManager.java:3717)
	at org.rhq.core.pc.inventory.InventoryManager.initialize(InventoryManager.java:301)
	at org.rhq.core.pc.PluginContainer.initialize(PluginContainer.java:292)
	at org.rhq.enterprise.agent.AgentMain.startPluginContainer(AgentMain.java:2084)
	at org.rhq.enterprise.agent.AgentMain.start(AgentMain.java:757)
	at org.rhq.enterprise.agent.AgentMain.main(AgentMain.java:461)
Caused by: org.rhq.core.clientapi.agent.PluginContainerException: [Warning] Resource classLoader not found for Resource[id=10467, uuid=2aba853c-32a4-4776-b4ee-55b037e2b088, type={JBossFuse}JBoss Fuse Container, key=JBoss Fuse Container{/home/hudson/jboss-a-mq-6.2.1.redhat-084}, name=JBoss Fuse Container [root]{/home/hudson/jboss-a-mq-6.2.1.redhat-084} JBoss Fuse Container [root], parent=vprusa-jon-amq.bc.jonqe.lab.eng.bos.redhat.com, version=1.2.0.redhat-621084] - cannot create ResourceComponent.
	at org.rhq.core.clientapi.agent.PluginContainerException.wrapIfNecessary(PluginContainerException.java:69)
	at org.rhq.core.clientapi.agent.PluginContainerException.(PluginContainerException.java:96)
	... 10 more

Comment 4 Filip Brychta 2017-04-06 15:32:36 UTC
Closing this bz because Fuse plugin issues are tracking in JIRA - https://issues.jboss.org/browse/FUSEJON-134


Note You need to log in before you can comment on or make changes to this bug.