Bug 1418256 - appliance_console backup restore fails with HA setup where pg_restore works fine
Summary: appliance_console backup restore fails with HA setup where pg_restore works fine
Keywords:
Status: CLOSED DUPLICATE of bug 1561075
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: luke couzens
URL:
Whiteboard: HA:black
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 11:46 UTC by luke couzens
Modified: 2018-05-03 18:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-03 18:18:08 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description luke couzens 2017-02-01 11:46:38 UTC
Description of problem:Trying to restore local backup to HA db fails through appliance_console with 'Restore Failed', however running the same restore using 'pg_restore' works fine with no errors.


Version-Release number of selected component (if applicable):5.7.1.0


How reproducible:100%


Steps to Reproduce:
1.Setup HA env following [0]
2.Add provider
3.Backup db (pg_dump was my method)
4.Stop evm service to close connections to db
5.dropdb
6.createdb
7.launch appliance_console
8.select option 7 for restore

Actual results:Restore Fails


Expected results:Restore completes successfully


Additional info:
[0] https://access.redhat.com/documentation/en/red-hat-cloudforms/4.2/single/configuring-high-availability/

On a side note, to drop the db I had to stop/start rh-postgresql95-postgresql as it still had a connection open to the db. This could of been what was causing appliance_console restore to fail, whereas pg_restore could of just been ignoring this connection.

Comment 2 Nick Carboni 2018-05-03 18:18:08 UTC

*** This bug has been marked as a duplicate of bug 1561075 ***


Note You need to log in before you can comment on or make changes to this bug.