Bug 1418285 - Remove orphan large objects fails with did not complete after 700827 ms
Summary: Remove orphan large objects fails with did not complete after 700827 ms
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Performance, Database, Plugin - Postgres
Version: JON 3.3.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 12:59 UTC by Filip Brychta
Modified: 2017-02-01 13:30 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 13:30:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2017-02-01 12:59:42 UTC
Description of problem:
When having lot of objects in pg_largeobject operation Remove orphan large objects fails with did not complete after 700827 ms.

I had 606 distinct objects there out of which 600 were representing war files (10MB each).

It seems the operation finished eventually because second invocation took 2s and result was Query removed 0 orphan large objects.


Version-Release number of selected component (if applicable):
JON3.3.8.ER02

How reproducible:
Always

Steps to Reproduce:
1. install JON3.3.7 with postgresql 9.x
2. deploy 300 different wars to EAP, size of each war should be 10MB
3. upgrade to JON 3.3.8
4. run Remove orphan large objects (rhq Postgres Server->rhq database->Operations)

Actual results:
Operations fails with did not complete after 700827 ms
But it seems the clean up job was finished eventually. All orphaned objects from pg_largeobject were removed.

Expected results:
Operation is successful

Additional info:

Comment 1 Filip Brychta 2017-02-01 13:30:50 UTC
Closing as not a bug since it's possible to define operation timeout in UI.


Note You need to log in before you can comment on or make changes to this bug.