Bug 1418289 - --noipv4 kickstart network command option results in traceback when defined via %pre
Summary: --noipv4 kickstart network command option results in traceback when defined v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
: 1398192 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 13:16 UTC by Radek Vykydal
Modified: 2017-08-01 08:53 UTC (History)
4 users (show)

Fixed In Version: anaconda-21.48.22.96-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 08:53:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2293 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC

Description Radek Vykydal 2017-02-01 13:16:32 UTC
RHEL 7.3 GA.

My reproducer (kickstart test [1]):

Two of three devices activated in initrd by
ip=ens3:dhcp ip=ens4:dhcp
Devices (re)configured by kickstart fetched from network

%include /tmp/ksinclude

%pre
echo "network --device=ens4 --noipv4 --no-activate --onboot=yes" >> /tmp/ksinclude
echo "network --device=ens5 --noipv4 --activate --onboot=no" >> /tmp/ksinclude
%end

The traceback:

Starting installer, one moment...
anaconda 21.48.22.94-1 for Red Hat Enterprise Linux 7.4 (pre-release) started.
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 1318, in networkInitialize
    devnames = apply_kickstart(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 1300, in apply_kickstart
    added_connections = add_connection_for_ksdata(network_data, dev_name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 569, in add_connection_for_ksdata
    nm.nm_add_connection(values)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 931, in nm_add_connection
    connection = proxy.AddConnection('(a{sa{sv}})', settings)
  File "/usr/lib64/python2.7/site-packages/gi/overrides/Gio.py", line 171, in __call__
    None)
GLib.Error: g-io-error-quark: GDBus.Error:org.freedesktop.NetworkManager.Settings.Connection.MissingProperty: ipv4.method: property is missing (36)
Exception AttributeError: "'NoneType' object has no attribute 'udev_unref'" in <bound method Context.__del__ of <pyudev.core.Context object at 0x7f0e5f383710>> ignored

[1]
https://github.com/rhinstaller/kickstart-tests/blob/master/network-noipv4-pre.sh
https://github.com/rhinstaller/kickstart-tests/blob/master/network-noipv4-pre.ks.in

Comment 1 Radek Vykydal 2017-02-01 13:22:11 UTC
https://github.com/rhinstaller/anaconda/pull/943

Comment 2 Radek Vykydal 2017-02-02 09:05:33 UTC
*** Bug 1398192 has been marked as a duplicate of this bug. ***

Comment 3 Radek Vykydal 2017-02-02 09:07:33 UTC
A simpler reproducer can be found in https://bugzilla.redhat.com/show_bug.cgi?id=1398192#c0.

Comment 6 Peter Kotvan 2017-05-09 16:14:25 UTC
Verified on RHEL-7.4-20170504.0 with anaconda-21.48.22.111-1.el7. Thanks.

Comment 7 errata-xmlrpc 2017-08-01 08:53:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.