Bug 1418294 - binary modules can not be installed on RHEL-6 devtoolset not enabled
Summary: binary modules can not be installed on RHEL-6 devtoolset not enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: nodejs
Version: rh-nodejs6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: alpha
: 2.4
Assignee: Zuzana Svetlikova
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 13:47 UTC by Miroslav Hradílek
Modified: 2017-04-26 10:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-26 10:12:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1145 0 normal SHIPPED_LIVE new packages: rh-nodejs6 2017-04-26 13:48:12 UTC

Description Miroslav Hradílek 2017-02-01 13:47:17 UTC
Description of problem:
Binary modules that require rebuild on installation time can not be installed on RHEL-6 because gyp can not find compiler. When I manually enable devtoolset the module is installed successfully

Version-Release number of selected component (if applicable):
UNRELEASED:
rh-nodejs6-2.4-4.el6.x86_64
rh-nodejs6-nodejs-6.9.1-1.el6.x86_64
rh-nodejs6-npm-3.10.9-2.el6.noarch
rh-nodejs6-gyp-0.1-0.11.1617svn.el6.noarch
rh-nodejs6-node-gyp-3.4.0-1.el6.noarch

Steps to Reproduce:
1. npm install contextify

Actual results:
Fails to install.

Expected results:
Enable devtoolset automatically and install module.

Additional info
Worked on rh-nodejs4.

Comment 4 errata-xmlrpc 2017-04-26 10:12:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1145


Note You need to log in before you can comment on or make changes to this bug.