Bug 1418326 - ktimetracker hangs
Summary: ktimetracker hangs
Keywords:
Status: CLOSED DUPLICATE of bug 917848
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 14:48 UTC by Robert Story
Modified: 2017-02-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 15:37:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Robert Story 2017-02-01 14:48:45 UTC
Description of problem:
After some time, ktimetracker hangs and becomes unresponsive

Version-Release number of selected component (if applicable):
Name        : ktimetracker
Version     : 4.14.10
Release     : 27.fc25
Architecture: x86_64
Source RPM  : kdepim4-4.14.10-27.fc25.src.rpm

How reproducible:
Very


Steps to Reproduce:
1. run ktimetracker
2. start a timer. stop a timer
3. leave idle for a long time (like overnight)

Actual results:
stops responding to key or mouse events

Expected results:
works normally

Additional info:
install from kde spin, all packages up to date.

stacktrace from gdb:

(gdb) bt
#0  0x00007f51c89d25dd in write () at /lib64/libpthread.so.0
#1  0x00007f51c1a2a7d0 in gamin_write_byte () at /lib64/libfam.so.0
#2  0x00007f51c1a2a965 in gamin_send_request () at /lib64/libfam.so.0
#3  0x00007f51c1a2c3fa in FAMCancelMonitor () at /lib64/libfam.so.0
#4  0x00007f51c91f8e48 in KDirWatchPrivate::removeWatch(KDirWatchPrivate::Entry*) () at /lib64/libkdecore.so.5
#5  0x00007f51c91fb9a3 in KDirWatchPrivate::removeEntry(KDirWatch*, KDirWatchPrivate::Entry*, KDirWatchPrivate::Entry*) () at /lib64/libkdecore.so.5
#6  0x00007f51c91fbc1d in KDirWatchPrivate::removeEntry(KDirWatch*, QString const&, KDirWatchPrivate::Entry*) () at /lib64/libkdecore.so.5
#7  0x00007f51c91fc512 in KDirWatch::removeFile(QString const&) () at /lib64/libkdecore.so.5
#8  0x00007f51b073e928 in timetrackerstorage::saveCalendar() () at /usr/lib64/kde4/ktimetrackerpart.so
#9  0x00007f51b074053b in timetrackerstorage::save(TaskView*) () at /usr/lib64/kde4/ktimetrackerpart.so
#10 0x00007f51b0755d74 in TaskView::save() () at /usr/lib64/kde4/ktimetrackerpart.so
#11 0x00007f51b0772e25 in TaskView::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) [clone .part.22] () at /usr/lib64/kde4/ktimetrackerpart.so
#12 0x00007f51c8d8c090 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#13 0x00007f51c8d91c83 in QObject::event(QEvent*) () at /lib64/libQtCore.so.4
#14 0x00007f51c9d5cecc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#15 0x00007f51c9d63dcc in QApplication::notify(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#16 0x00007f51cad32c8a in KApplication::notify(QObject*, QEvent*) () at /lib64/libkdeui.so.5
#17 0x00007f51c8d77eed in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQtCore.so.4
#18 0x00007f51c8daa910 in QTimerInfoList::activateTimers() () at /lib64/libQtCore.so.4
#19 0x00007f51c8da7a81 in timerSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQtCore.so.4
#20 0x00007f51c392fe42 in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#21 0x00007f51c39301c0 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#22 0x00007f51c393026c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#23 0x00007f51c8da845e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#24 0x00007f51c9e055a6 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtGui.so.4
#25 0x00007f51c8d767bf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#26 0x00007f51c8d76b25 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#27 0x00007f51c8d7c779 in QCoreApplication::exec() () at /lib64/libQtCore.so.4
#28 0x0000560e658eb3f3 in main ()

Comment 1 Rex Dieter 2017-02-01 15:37:29 UTC
likely gamin bug #917848

*** This bug has been marked as a duplicate of bug 917848 ***


Note You need to log in before you can comment on or make changes to this bug.