Bug 1418363 - Missing port 5000 for capsule communication to Satellite
Summary: Missing port 5000 for capsule communication to Satellite
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Docs Install Guide
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: Stephen Wadeley
QA Contact: Lucie Jirakova
URL:
Whiteboard:
Depends On:
Blocks: 1424952
TreeView+ depends on / blocked
 
Reported: 2017-02-01 16:10 UTC by Johan Swensson
Modified: 2019-09-26 14:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1424952 (view as bug list)
Environment:
Last Closed: 2017-03-23 15:13:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Johan Swensson 2017-02-01 16:10:45 UTC
Document URL: 
https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/installation-guide/chapter-2-preparing-your-environment-for-installation


Section Number and Name: 
2.5. Ports and Firewalls Requirements

Describe the issue: 
Since Satellite 6.2 Capsules needs to be able to communicate to Satellite on port 5000/tcp

Suggestions for improvement: 
Add the required port to table Table 2.6. Ports for Capsule to Satellite Communication


Additional information: 
Additionally clients needs to communicate to Capsules/Satellite on port 5000 when pulling Docker content. Might be a good idea to add the port to table Table 2.5. Ports for Client to Capsule Communication and Table 2.4. Ports for Client to Satellite Communication

Comment 1 Stephen Wadeley 2017-02-01 16:55:13 UTC
Hello


Thank you for raising this bug.

Comment 2 Stephen Wadeley 2017-02-01 21:36:10 UTC
Hello Johan

This port is not listed in the matrix table for Capsule to Satellite communications. I will therefore seek confirmation from Docker SMEs. 

The port should be added to the matrix table.


Hello Partha Aji and Daniel Lobato Garcia

Can you confirm the need for TCP 5000 to be opened on Satellite and Capsule as mentioned in comment 0?


Thank you

Comment 3 Daniel Lobato Garcia 2017-02-09 12:33:58 UTC
Yes, I can confirm port 5000 is necessary in order to use the Docker registry with the default configuration.

Comment 4 Stephen Wadeley 2017-02-09 12:36:16 UTC
Thank you Daniel

Comment 14 Stephen Wadeley 2017-03-23 15:13:19 UTC
Hello


These changes are now live on the customer portal.

Thank you


Note You need to log in before you can comment on or make changes to this bug.