Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1418369 - Need way to revert commits or mark tests bad without testing
Summary: Need way to revert commits or mark tests bad without testing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 16:30 UTC by Jeff Darcy
Modified: 2017-04-17 05:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-17 05:46:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jeff Darcy 2017-02-01 16:30:57 UTC
As discussed in today's community meeting, we need a way to "dig ourselves out of the hole" quickly when work is blocked by sporadically failing tests.  Specifically, there should be a way to exempt patches from testing which (a) revert a previous commit or (b) mark a test as bad.  Gerrit has permissions that allow specified users to bypass tests by pushing to refs/heads/xxx instead of refs/for/xxx.  This permission should be enabled for project architects (and probably not for others).  If we can further extend or limit this ability by recognizing reverts and test markings for what they are, that's great but not immediately necessary.

Comment 1 Niels de Vos 2017-02-14 12:11:28 UTC
Should we not have a discussion or at least a notification about this on the maintainers list? I think permissions to push changes without reviews can be done by release managers (because they need to be able to push tags?), but fine-tuning the permissions sounds like a good idea.

Just some guidelines or recommendations on which changes to push and 'rules' to notify relevant persons and track progress would be good.

Comment 2 Jeff Darcy 2017-02-14 12:23:22 UTC
Yes, there should be a policy discussion about this, but it's moot if the technical capability isn't implemented.  Therefore, I think the two efforts can proceed in parallel.

Comment 3 Nigel Babu 2017-04-17 05:46:53 UTC
The technical capability is now done. There's a team called gluster-plumbers who have permission to push to any branch directly. It has Vijay, Jeff, and Shyam. As far as infra is concerned this is fixed. If the policy dictates changes to this, please file a bug.


Note You need to log in before you can comment on or make changes to this bug.