Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418372 - Network Topology does not show Cloud Routers
Summary: Network Topology does not show Cloud Routers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Tzu-Mainn Chen
QA Contact: Ido Ovadia
URL:
Whiteboard: openstack:sdn
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 16:36 UTC by Ido Ovadia
Modified: 2018-07-12 18:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-12 18:10:33 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
Network Topology (186.93 KB, image/png)
2017-02-01 16:36 UTC, Ido Ovadia
no flags Details
Router summary (123.62 KB, image/png)
2017-02-01 16:38 UTC, Ido Ovadia
no flags Details

Description Ido Ovadia 2017-02-01 16:36:07 UTC
Created attachment 1246740 [details]
Network Topology

Description of problem:
=======================
Network Topology does not show Cloud Routers


Version-Release number of selected component:
=============================================
5.7.1.0.20170124142149_8a5f4d5


How reproducible:
=================
100%


Steps to Reproduce:
===================
Note: I have attached the interface to the router via OpenStack CLI due to https://bugzilla.redhat.com/show_bug.cgi?id=1413212

1. Create a router on overcloud
2. Set a gateway 
3. Add an internal network to the router
4. On CFME: Verify the router exists on Network Routers list 
5. On CFME: Browse Networks --> Topology 

Actual results:
===============
The router does not appears on topology (Note: Network Routers entity selected)

Expected results:
=================
Router should appear on topology

Additional info:
================
Screenshots are enclosed

Comment 1 Ido Ovadia 2017-02-01 16:38:55 UTC
Created attachment 1246741 [details]
Router summary

Comment 2 Oleksandr Kolisnyk 2017-02-23 15:49:07 UTC
Reproduced it on CFME 5.7.1.3 with RHOS 10
Also, routers relationships do not display any info (connected interfaces, instances)

Comment 3 Ladislav Smola 2017-03-13 16:15:24 UTC
@Mainn, can you check this out? Routers are being used only by the OpenStack currently.

Comment 4 Tzu-Mainn Chen 2017-03-16 14:37:21 UTC
Hi Ido!  Just to make sure I have this right, can you copy the openstack CLI commands you're using?

Comment 8 Tzu-Mainn Chen 2017-05-10 20:24:03 UTC
Fixed by: https://github.com/ManageIQ/manageiq-providers-openstack/pull/31

Comment 11 Ido Ovadia 2018-06-12 11:59:28 UTC
Verified
========
CFME 5.8.4.4


Note You need to log in before you can comment on or make changes to this bug.