Bug 1418391 - Firewalld update to 0.4.4 needs selinux-policy update
Summary: Firewalld update to 0.4.4 needs selinux-policy update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1419957 (view as bug list)
Depends On:
Blocks: 1414584
TreeView+ depends on / blocked
 
Reported: 2017-02-01 17:38 UTC by Thomas Woerner
Modified: 2020-04-15 15:12 UTC (History)
9 users (show)

Fixed In Version: selinux-policy-3.13.1-118.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2947901 0 None None None 2017-02-28 07:56:43 UTC
Red Hat Product Errata RHBA-2017:1861 0 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description Thomas Woerner 2017-02-01 17:38:14 UTC
Description of problem:

firewalld needs to be able to identify netfilter helpers. For this is needs to be able to getattr, open, search and read modules_object_t:dir.

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-102.el7_3.13.noarch

How reproducible:
Always

Actual results:

type=AVC msg=audit(1485969134.528:86): avc:  denied  { search } for  pid=600 comm="firewalld" name="modules" dev="vda1" ino=1251755 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir

Additional info:

The fix has been merged into fedora-selinux: https://github.com/fedora-selinux/selinux-policy/pull/171

Comment 1 Milos Malik 2017-02-01 18:56:51 UTC
Could you collect all SELinux denials that are triggered by the 0.4.4 firewalld?

# ausearch -m avc -m user_avc -m selinux_err -m user_selinux_err -i -ts today

Thanks.

Comment 2 Thomas Woerner 2017-02-02 12:28:24 UTC
These are the related AVC messages gathered by deactivating dontaudit and allowing one after the other with the command 

# ausearch -m avc -m user_avc -m selinux_err -m user_selinux_err -i -ts today | grep firewalld  | grep module

type=AVC msg=audit(02/02/2017 11:21:30.454:1092) : avc:  denied  { search } for  pid=7323 comm=firewalld name=modules dev="vda1" ino=1251755 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir 
type=AVC msg=audit(02/02/2017 11:25:39.678:1217) : avc:  denied  { getattr } for  pid=8039 comm=firewalld path=/usr/lib/modules/3.10.0-514.2.2.el7.x86_64/kernel/net/netfilter dev="vda1" ino=25892966 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir 
type=AVC msg=audit(02/02/2017 11:26:35.079:1322) : avc:  denied  { read } for  pid=8335 comm=firewalld name=netfilter dev="vda1" ino=25892966 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir 
type=AVC msg=audit(02/02/2017 11:27:24.426:1372) : avc:  denied  { open } for  pid=8570 comm=firewalld path=/usr/lib/modules/3.10.0-514.2.2.el7.x86_64/kernel/net/netfilter dev="vda1" ino=25892966 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir 
allow firewalld_t modules_object_t:dir { getattr open read search };

Comment 5 Lukas Vrabec 2017-02-08 14:38:38 UTC
*** Bug 1419957 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2017-08-01 15:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.