Bug 1418393 - Certain ppc64le packages in RHSA-2016:0448 do not appear to be associated with this errata
Summary: Certain ppc64le packages in RHSA-2016:0448 do not appear to be associated wit...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.2
Hardware: ppc64le
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: John Francini
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1420851
TreeView+ depends on / blocked
 
Reported: 2017-02-01 17:43 UTC by Rick Dixon
Modified: 2020-12-14 08:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-28 14:50:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rick Dixon 2017-02-01 17:43:17 UTC
Description of problem:

We have a Satellite 6 customer utilizing RHEL 7 PPC64 LE repositories who is trying to filter all errata released after 2/17/2016, however the following packages remain completely unfiltered (even when specified by errata ID):

~~~
libsmbclient-4.2.3-12.el7_2.ppc64le
libwbclient-4.2.3-12.el7_2.ppc64le
samba-4.2.3-12.el7_2.ppc64le
samba-client-4.2.3-12.el7_2.ppc64le
samba-client-libs-4.2.3-12.el7_2.ppc64le
samba-common-libs-4.2.3-12.el7_2.ppc64le
samba-common-tools-4.2.3-12.el7_2.ppc64le
samba-libs-4.2.3-12.el7_2.ppc64le
samba-winbind-4.2.3-12.el7_2.ppc64le
samba-winbind-clients-4.2.3-12.el7_2.ppc64le
samba-winbind-modules-4.2.3-12.el7_2.ppc64le
~~~

The following RHN announcement seems to list all of these packages as included:

   =================================================
   RHSA-2016:0448 - Security Advisory
   https://rhn.redhat.com/errata/RHSA-2016-0448.html
   =================================================
   --------
   PPC64LE:
   --------
   libsmbclient-4.2.3-12.el7_2.ppc64le.rpm
   libsmbclient-devel-4.2.3-12.el7_2.ppc64le.rpm
   libwbclient-4.2.3-12.el7_2.ppc64le.rpm
   libwbclient-devel-4.2.3-12.el7_2.ppc64le.rpm
   samba-4.2.3-12.el7_2.ppc64le.rpm
   samba-client-4.2.3-12.el7_2.ppc64le.rpm
   samba-client-libs-4.2.3-12.el7_2.ppc64le.rpm
   samba-common-4.2.3-12.el7_2.noarch.rpm
   samba-common-libs-4.2.3-12.el7_2.ppc64le.rpm
   samba-common-tools-4.2.3-12.el7_2.ppc64le.rpm
   samba-dc-4.2.3-12.el7_2.ppc64le.rpm
   samba-dc-libs-4.2.3-12.el7_2.ppc64le.rpm
   samba-debuginfo-4.2.3-12.el7_2.ppc64le.rpm
   samba-devel-4.2.3-12.el7_2.ppc64le.rpm
   samba-libs-4.2.3-12.el7_2.ppc64le.rpm
   samba-pidl-4.2.3-12.el7_2.noarch.rpm
   samba-python-4.2.3-12.el7_2.ppc64le.rpm
   samba-test-4.2.3-12.el7_2.ppc64le.rpm
   samba-test-devel-4.2.3-12.el7_2.ppc64le.rpm
   samba-test-libs-4.2.3-12.el7_2.ppc64le.rpm
   samba-winbind-4.2.3-12.el7_2.ppc64le.rpm
   samba-winbind-clients-4.2.3-12.el7_2.ppc64le.rpm
   samba-winbind-krb5-locator-4.2.3-12.el7_2.ppc64le.rpm
   samba-winbind-modules-4.2.3-12.el7_2.ppc64le.rpm


However, the below CDN announcement only lists noarch packages for PPC64LE:

   =================================================
   RHSA-2016:0448 - Security Advisory
   https://access.redhat.com/errata/RHSA-2016:0448
   =================================================
   -------
   ppc64le
   -------
   samba-common-4.2.3-12.el7_2.noarch.rpm
   samba-pidl-4.2.3-12.el7_2.noarch.rpm

On my own Satellite 6.2.7, I can see where no ppc64le architecture packages are associated with announcement RHSA-2016:0448:

   foreman=# SELECT id,errata_id FROM katello_errata WHERE errata_id LIKE '%RHSA-2016:0448%';
   id  |   errata_id    
   -----+----------------
   964 | RHSA-2016:0448
   (1 row)

   foreman=# SELECT id,erratum_id,nvrea FROM katello_erratum_packages WHERE erratum_id = '964';
     id   | erratum_id |                    nvrea                     
   -------+------------+----------------------------------------------
    16846 |        964 | libsmbclient-3.6.23-25.el6_7.i686
    16848 |        964 | libsmbclient-3.6.23-25.el6_7.x86_64
     5053 |        964 | libsmbclient-4.2.3-12.el7_2.i686
     5049 |        964 | libsmbclient-4.2.3-12.el7_2.x86_64
     5052 |        964 | libwbclient-4.2.3-12.el7_2.i686
     5045 |        964 | libwbclient-4.2.3-12.el7_2.x86_64
    16844 |        964 | samba-3.6.23-25.el6_7.x86_64
     5040 |        964 | samba-4.2.3-12.el7_2.x86_64
    16850 |        964 | samba-client-3.6.23-25.el6_7.x86_64
     5057 |        964 | samba-client-4.2.3-12.el7_2.x86_64
     5048 |        964 | samba-client-libs-4.2.3-12.el7_2.i686
     5046 |        964 | samba-client-libs-4.2.3-12.el7_2.x86_64
    16845 |        964 | samba-common-3.6.23-25.el6_7.i686
    16852 |        964 | samba-common-3.6.23-25.el6_7.x86_64
     5054 |        964 | samba-common-4.2.3-12.el7_2.noarch
     5043 |        964 | samba-common-libs-4.2.3-12.el7_2.x86_64
     5056 |        964 | samba-common-tools-4.2.3-12.el7_2.x86_64
     5050 |        964 | samba-libs-4.2.3-12.el7_2.i686
     5044 |        964 | samba-libs-4.2.3-12.el7_2.x86_64
     5041 |        964 | samba-python-4.2.3-12.el7_2.x86_64
    16851 |        964 | samba-winbind-3.6.23-25.el6_7.x86_64
     5055 |        964 | samba-winbind-4.2.3-12.el7_2.x86_64
    16847 |        964 | samba-winbind-clients-3.6.23-25.el6_7.i686
    16849 |        964 | samba-winbind-clients-3.6.23-25.el6_7.x86_64
     5051 |        964 | samba-winbind-clients-4.2.3-12.el7_2.x86_64
     5042 |        964 | samba-winbind-modules-4.2.3-12.el7_2.i686
     5047 |        964 | samba-winbind-modules-4.2.3-12.el7_2.x86_64
   (27 rows)

Note that no ppc64le architecture packages are associated with this announcement in the postgres database, only the noarch package (samba-common) which is listed in the CDN announcement.


How reproducible:

Always


Steps to Reproduce:
1. Create a content view in Satellite 6 which includes the RHEL 7 PPC64LE repository and attempt to filter RHSA-2016:0448 by date or ID

2. Publish a new version of the content view

3. In the fresh CV version, check the packages and you will see all of the ones listed above. The only package effectively filtered is the samba-common.noarch


Actual results:

Packages with ppc64le architecture do not get filtered appropriately.


Expected results:

The ppc64le packages should be associated with this announcement (or release date) and should be filtered appropriately.


Additional info:

Reproducer available.

Comment 1 Lubos Kocman 2017-02-02 09:24:34 UTC
I just did, repush RHSA-2016:0448-07 advisory, if this won't help. We'll have to move it to content-delivery team. Moving to ON_QA.

Lubos

Comment 3 John Francini 2017-02-07 23:00:33 UTC
I just looked at the advisory just now, and all the packages for PPC64LE appear to be in place.

Comment 4 Rick Dixon 2017-02-08 14:17:29 UTC
Hello,

Thank you, the advisory does appear to list the appropriate ppc64le packages now.

However, I just resynced the repo and refreshed the metadata on my Satellite, and the ppc64le packages from this announcement are still not associated with this erratum ID:

~~~
foreman=# SELECT id,errata_id FROM katello_errata WHERE errata_id LIKE '%RHSA-2016:0448%';
 id  |   errata_id    
-----+----------------
 964 | RHSA-2016:0448
(1 row)

foreman=# select id,erratum_id,nvrea from katello_erratum_packages where erratum_id = '964';
  id   | erratum_id |                    nvrea                     
-------+------------+----------------------------------------------
 16846 |        964 | libsmbclient-3.6.23-25.el6_7.i686
 16848 |        964 | libsmbclient-3.6.23-25.el6_7.x86_64
  5053 |        964 | libsmbclient-4.2.3-12.el7_2.i686
  5049 |        964 | libsmbclient-4.2.3-12.el7_2.x86_64
  5052 |        964 | libwbclient-4.2.3-12.el7_2.i686
  5045 |        964 | libwbclient-4.2.3-12.el7_2.x86_64
 16844 |        964 | samba-3.6.23-25.el6_7.x86_64
  5040 |        964 | samba-4.2.3-12.el7_2.x86_64
 16850 |        964 | samba-client-3.6.23-25.el6_7.x86_64
  5057 |        964 | samba-client-4.2.3-12.el7_2.x86_64
  5048 |        964 | samba-client-libs-4.2.3-12.el7_2.i686
  5046 |        964 | samba-client-libs-4.2.3-12.el7_2.x86_64
 16845 |        964 | samba-common-3.6.23-25.el6_7.i686
 16852 |        964 | samba-common-3.6.23-25.el6_7.x86_64
  5054 |        964 | samba-common-4.2.3-12.el7_2.noarch
  5043 |        964 | samba-common-libs-4.2.3-12.el7_2.x86_64
  5056 |        964 | samba-common-tools-4.2.3-12.el7_2.x86_64
  5050 |        964 | samba-libs-4.2.3-12.el7_2.i686
  5044 |        964 | samba-libs-4.2.3-12.el7_2.x86_64
  5041 |        964 | samba-python-4.2.3-12.el7_2.x86_64
 16851 |        964 | samba-winbind-3.6.23-25.el6_7.x86_64
  5055 |        964 | samba-winbind-4.2.3-12.el7_2.x86_64
 16847 |        964 | samba-winbind-clients-3.6.23-25.el6_7.i686
 16849 |        964 | samba-winbind-clients-3.6.23-25.el6_7.x86_64
  5051 |        964 | samba-winbind-clients-4.2.3-12.el7_2.x86_64
  5042 |        964 | samba-winbind-modules-4.2.3-12.el7_2.i686
  5047 |        964 | samba-winbind-modules-4.2.3-12.el7_2.x86_64
(27 rows)
~~~

The reason this is concerning is because it breaks content view filtering for ppc64le customers. For instance, if I wanted to create a content view comprised entirely of ppc64le repositories which excludes the following:

   - Any errata released after 2/15/2016
   - Any packages associated with RHSA-2016:0448

At this time, *only* the samba-common.noarch package is effectively excluded from the content view with these filters in place. All ppc64le architecture packages slip through the filters and end up causing package dependency issues in later yum transactions.

The current workaround is to set up an additional filter which specifically excludes individual ppc64le packages based on version number. This works, but doesn't address the underlying issue.

Please let me know if you have any questions or if I can be of any help in getting this resolved.

Thank you kindly,

Rick

Comment 5 Craig Donnelly 2017-02-08 21:20:13 UTC
Updated and Re-opened the RCM Ticket to reflect that this issue is not resolved and needs to have the packages tied to the errata via the repodata.

Continue to follow the RCM.


Note You need to log in before you can comment on or make changes to this bug.