Bug 1418413 - iframe rendering broken since 2.15.3
Summary: iframe rendering broken since 2.15.3
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk4
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Popela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 19:10 UTC by Dennis Gilmore
Modified: 2017-02-07 09:51 UTC (History)
7 users (show)

Fixed In Version: webkitgtk4-2.15.4-4.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 14:02:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
WebKit Project 167876 0 None None None 2017-02-06 13:44:32 UTC

Description Dennis Gilmore 2017-02-01 19:10:43 UTC
Description of problem:
loading new messages in the message pane hangs frequently. it seems to be that if the message has not quite loaded and i go to a different message it never loads

Version-Release number of selected component (if applicable):
evolution-3.23.4-1.fc26.x86_64
evolution-data-server-3.23.4-1.fc26.x86_64
evolution-help-3.23.4-1.fc26.noarch
evolution-ews-3.23.4-1.fc26.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Milan Crha 2017-02-02 08:57:09 UTC
Thanks for a bug report. There had been few rawhide users reporting similar issues and a downgrade of webkitgtk4 helped. What is your current webkitgtk4 version and could you downgrade it by one or two versions, please?

You probably know, but just in case, you can find older builds in koji:
https://koji.fedoraproject.org/koji/packageinfo?packageID=19030

Comment 2 Dennis Gilmore 2017-02-02 09:12:40 UTC
I have webkitgtk4-2.15.3-1.fc26.x86_64 installed. will test the previous build

Comment 3 Dennis Gilmore 2017-02-02 10:05:57 UTC
after installing webkitgtk4-2.15.2-1.fc26.x86_64 things are better but I can trigger almost the same behaviour still. difference is that I just get a blank pane rather than saying its loading the message

Comment 4 Dennis Gilmore 2017-02-02 10:07:11 UTC
29923 dennis    20   0 2253764  91316  60636 R  98.7  1.1   3:34.19 /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 38                                                                                                                                           


the fan has kicked in also on my system

Comment 5 Milan Crha 2017-02-02 15:37:34 UTC
Get a backtrace of that web process, please? It can be stuck somewhere. My preferred command is:

   $ gdb --batch --ex "t a a bt" -pid=PID &>bt.txt

Please check the bt.txt for any private information, like passwords, email address, server addresses,... I usually search for "pass" at least (quotes for clarity only).

Comment 6 Yanko Kaneti 2017-02-03 11:27:02 UTC
webkitgtk4-2.15.4 seems to help here. The mail view never get stuck indefinitely like with 2.15.3.  As for the occasional empty preview/mail - I've rarelty seen it here and never permanent, switching messages always "fixes" it.

Comment 7 Yanko Kaneti 2017-02-03 11:40:33 UTC
Ugh. I've spoken too soon. After more the 2-3 hours continuous use without problems it got stuck again. I'll try to investigate more

Comment 8 Yanko Kaneti 2017-02-03 12:10:18 UTC
It seems like here I have a 95% chance of getting it stuck while attempting to preview the latest Fedora Rawhide Report on devel or test lists eg:

From: Fedora Rawhide Report <rawhide@fedoraproject.org>
To: test@lists.fedoraproject.org
Subject: Fedora rawhide compose report: 20170203.n.0 changes
Message-ID: <20170203113215.GA3189@rawhide-composer.phx2.fedoraproject.org>

Sometimes it works for some reason...

Comment 9 Milan Crha 2017-02-03 13:41:15 UTC
I just tried webkitgtk4-2.15.3-1.fc26.x86_64 with your message and the only thing I get are headers and then two empty frames below it. When I click the top empty frame, then in enlarges to a size which I'd expect for the message content, but there is no text shown there. The WebKitWebProcess doesn't show anything stuck there, thus it's something else than I initially thought of. I cannot test with 2.15.4, due to current dependency hell.

Downgrading to webkitgtk4-2.15.2-1.fc26.x86_64 makes the mail show properly, 5 of 5 tries.

Comment 10 Tomas Popela 2017-02-06 09:17:16 UTC
I can confirm this. I'm bisecting the commits between 2.15.2 and 2.15.3.


Note You need to log in before you can comment on or make changes to this bug.