Bug 1418417 - packaging: remove glusterfs-ganesha subpackage [NEEDINFO]
Summary: packaging: remove glusterfs-ganesha subpackage
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1418419
TreeView+ depends on / blocked
 
Reported: 2017-02-01 19:20 UTC by Kaleb KEITHLEY
Modified: 2017-05-30 18:40 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1418419 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:40:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
kkeithle: needinfo? (jrivera)


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2017-02-01 19:20:31 UTC
Description of problem:

now that storhaug is available in Fedora add dependency

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-02-01 19:22:24 UTC
REVIEW: https://review.gluster.org/16506 (packaging (storhaug): add storhaug dependency for glusterfs-ganesha) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Jose A. Rivera 2017-02-02 07:29:19 UTC
Is this really needed? Aren't you able to run NFS-Ganesha on its own without either GlusterFS or HA? In anything the dependency should be the other way around, and storhaug-nfs should depend on NFS-Ganesha.

--Jose

Comment 3 Soumya Koduri 2017-02-03 06:47:48 UTC
(In reply to Jose A. Rivera from comment #2)
> Is this really needed? Aren't you able to run NFS-Ganesha on its own without
> either GlusterFS or HA? In anything the dependency should be the other way
> around, and storhaug-nfs should depend on NFS-Ganesha.
> 
> --Jose

Agree. That was my understanding too. Shouldn't we be doing all nfs-ganesha HA related configuration using storehaug and deprecate Gluster CLIs?

Comment 4 Kaleb KEITHLEY 2017-02-04 12:11:30 UTC
Yeah, even before I saw the latest comments I was thinking instead to
1) completely delete glusterfs-ganesha sub-package
2) delete all ganesha CLIs from gluster/glusterd.

Revised patches coming soon.

Comment 5 Worker Ant 2017-02-06 12:05:11 UTC
REVIEW: https://review.gluster.org/16506 (packaging (ganesha): remove glusterfs-ganesha sub-package and related files) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 6 Worker Ant 2017-02-12 15:14:47 UTC
REVIEW: https://review.gluster.org/16506 (packaging: (ganesha) remove glusterfs-ganesha subpackage and related files)) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 7 Worker Ant 2017-02-20 12:46:54 UTC
REVIEW: https://review.gluster.org/16506 (packaging: (ganesha) remove glusterfs-ganesha subpackage and related files)) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 8 Worker Ant 2017-02-23 13:13:04 UTC
REVIEW: https://review.gluster.org/16506 (packaging: (ganesha) remove glusterfs-ganesha subpackage and related files)) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 9 Worker Ant 2017-03-21 17:14:34 UTC
COMMIT: https://review.gluster.org/16506 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 0cf2963f12a8b540a7042605d8c79f638fdf6cee
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Feb 1 07:50:17 2017 -0500

    packaging: (ganesha) remove glusterfs-ganesha subpackage and related files)
    
    Indiana Jones and the Temple of Ganesha HA, part two.
    
    remove glsuterfs-ganesha subpackage, superceded by storhaug
    
    Change-Id: I42a1fc59159add108d77080b9b130696216aa76d
    BUG: 1418417
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/16506
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>

Comment 10 Shyamsundar 2017-05-30 18:40:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.