Bug 141842 - Kernel source (little_endian.h?) broken. Sources wont compile
Kernel source (little_endian.h?) broken. Sources wont compile
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://www.linuxquestions.org/questio...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 18:24 EST by Duncan Mercer
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output from make when trying to compile equinox sources (11.29 KB, text/plain)
2004-12-03 18:28 EST, Duncan Mercer
no flags Details

  None (edit)
Description Duncan Mercer 2004-12-03 18:24:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
I'm trying to compile the source code for a third party driver for a
multi modem card from equinox
(http://http://www.equinox.com/drivers/superserial/eqnx_4.07.html).

I had no problem compiling the source for the drivers using kernerl
sources version 2.6.5

I'm getting a set of syntax when compiling the source code. The errors
reference the kernel file little_endian.h

Having googled (for little_endian.h) a bit I've found two other people
seeing the same problem when trying to compile sources for other
external packages.

I've attached a copy of the output errors from the compiler

Version-Release number of selected component (if applicable):
2.6.9-1.681

How reproducible:
Always

Steps to Reproduce:
1.installed kernel sources for ver 2.6.9-1.681 
2.built and installed a new kernel
3.install equinox sources (following instructions on equinox page)
4.Try to build equinox sources (either using SPECS or make directly)
    

Actual Results:  I get a series of syntax errors reported in the file
little_endian.h

Expected Results:  I should have been able to compile the sources
without generating errors

Additional info:
Comment 1 Duncan Mercer 2004-12-03 18:28:09 EST
Created attachment 107873 [details]
The output from make when trying to compile equinox sources
Comment 2 Duncan Mercer 2004-12-03 18:50:53 EST
I've just found someone posting what looks like a fix to this problem
http://www.ussg.iu.edu/hypermail/linux/kernel/0409.2/0723.html
Comment 3 Duncan Mercer 2004-12-07 05:05:45 EST
I tried compiling the same equinox sources under kernel-2.6.10 and
they compile without problems. 

I guess that the problem has been resolved in the later kernel, though
I cannot see the relevant change when looking at the little_endian.h
or at the types.h header.



Comment 4 Dave Jones 2005-07-15 16:11:06 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Duncan Mercer 2005-07-18 06:35:59 EDT
> If you have updated to Fedora Core 4 since this bug was opened.


I have upgraded to FC4 since opening this bug. I have not seen the problem at all
under FC4. I currently running a 2.6.11-1 kernel.

Best regards
Duncan

Note You need to log in before you can comment on or make changes to this bug.