Bug 1418446 - vnmul, and fnmul patterns in correct for -frounding-math
Summary: vnmul, and fnmul patterns in correct for -frounding-math
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gcc
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: Michael Petlan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 21:08 UTC by Carlos O'Donell
Modified: 2017-08-01 22:35 UTC (History)
3 users (show)

Fixed In Version: gcc-4.8.5-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:35:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNU Compiler Collection 66731 0 None None None 2017-02-02 11:01:04 UTC
Red Hat Product Errata RHBA-2017:2094 0 normal SHIPPED_LIVE gcc bug fix update 2017-08-01 19:36:07 UTC

Description Carlos O'Donell 2017-02-01 21:08:35 UTC
The glibc upstream regression testsuite run on RHEL7 shows failures in tgamma_upward.

testing float (without inline functions)
Failure: tgamma_upward (-0x1.86a08p+16): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x1.f40002p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x2.a00004p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x2.ee0004p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x3.200004p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x3.e80004p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x4.e20008p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x5.dc0008p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x5.f0e02p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.400008p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.d60008p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.e2fff8p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.e40008p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.e4fff8p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.e60008p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.ec0008p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.ecfff8p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.ee0008p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x6.eefff8p+8): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0x9.60001p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xa.c0001p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.4ffffp+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.60001p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.6ffffp+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.80001p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.c0001p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.cffffp+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.e0001p+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xb.effffp+4): errno set to 0, expected 34 (ERANGE)
Failure: tgamma_upward (-0xf.a0001p+4): errno set to 0, expected 34 (ERANGE)

This is because gcc PR/66731 is not fixed in RHEL7 system gcc.

"Bug 66731 - vnmul, fnmul patterns incorrect for -frounding-math "
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66731

Comment 4 Michael Petlan 2017-05-31 14:14:51 UTC
The related test passes on aarch64 with gcc-4.8.5-14.el7. The test is for aarch64 only.

VERIFIED.

Comment 5 errata-xmlrpc 2017-08-01 22:35:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2094


Note You need to log in before you can comment on or make changes to this bug.