Bug 1418471 - Incompatibility with GCC v7
Summary: Incompatibility with GCC v7
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: R
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1417385
Blocks: 1417331
TreeView+ depends on / blocked
 
Reported: 2017-02-01 23:02 UTC by E.N.
Modified: 2017-02-14 21:23 UTC (History)
2 users (show)

Fixed In Version: R-3.3.2-8.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-14 11:35:46 UTC
Type: Bug


Attachments (Terms of Use)

Description E.N. 2017-02-01 23:02:01 UTC
Description of problem:
Cannot upgrade GCC to version 7 because of broken dependencies between R-core and libgfortran.

Version-Release number of selected component (if applicable):
R-core-3.3.2-4.fc26.x86_64
openblas-Rblas-0.2.19-4.fc26.x86_64
libgfortran-6.3.1-2.fc26.x86_64 (installed)
libgfortran-7.0.1-0.3.fc26.x86_64 (targeted for upgrade)

How reproducible:

Steps to Reproduce:
1. dnf upgrade

Actual results:
Error: 
 Problem 1: cannot install both libgfortran-7.0.1-0.3.fc26.x86_64 and libgfortran-6.3.1-2.fc26.x86_64
  - package R-core-3.3.2-4.fc26.x86_64 requires libgfortran.so.3()(64bit), but none of the providers can be installed
  …
 Problem 2: cannot install both libgfortran-7.0.1-0.3.fc26.x86_64 and libgfortran-6.3.1-2.fc26.x86_64
  - package openblas-Rblas-0.2.19-4.fc26.x86_64 requires libgfortran.so.3()(64bit), but none of the providers can be installed
  - package gcc-gfortran-7.0.1-0.3.fc26.x86_64 requires libgfortran.so.4()(64bit), but none of the providers can be installed
  …
 Problem 3: problem with installed package openblas-Rblas-0.2.19-4.fc26.x86_64
  - package openblas-Rblas-0.2.19-4.fc26.x86_64 requires libgfortran.so.3()(64bit), but none of the providers can be installed
  - package libgfortran-6.3.1-2.fc26.x86_64 requires libquadmath = 6.3.1-2.fc26, but none of the providers can be installed
  …
 Problem 4: package R-core-devel-3.3.2-4.fc26.x86_64 requires R-core = 3.3.2-4.fc26, but none of the providers can be installed
  …
  - cannot install both libgfortran-7.0.1-0.3.fc26.x86_64 and libgfortran-6.3.1-2.fc26.x86_64
  …
  - nothing provides libgfortran.so.3 needed by R-core-3.3.2-4.fc26.i686
 Problem 5: problem with installed package R-core-3.3.2-4.fc26.x86_64
  …
 Problem 6: problem with installed package R-core-devel-3.3.2-4.fc26.x86_64
  …
 Problem 7: package R-devel-3.3.2-4.fc26.x86_64 requires R-core-devel = 3.3.2-4.fc26, but none of the providers can be installed
  …


Expected results:
Compatibility with GCC 7

Comment 1 Tom "spot" Callaway 2017-02-08 21:24:32 UTC
We're blocking on openblas, which is blocking on a bug involving ppc64le.

Comment 2 E.N. 2017-02-09 22:18:04 UTC
(In reply to Tom "spot" Callaway from comment #1)
Thanks for diving onto the issue.

Comment 3 Björn 'besser82' Esser 2017-02-13 23:38:53 UTC
Rebuild should be finished soon…

Comment 4 Björn 'besser82' Esser 2017-02-13 23:45:39 UTC
Build now fails for:

> configure: WARNING: unrecognized options: --disable-dependency-tracking
> configure: error: zlib library and headers are required
> RPM build errors:
> error: Bad exit status from /var/tmp/rpm-tmp.LLy9xc (%build)
>     Bad exit status from /var/tmp/rpm-tmp.LLy9xc (%build)
> Child return code was: 1

See:  https://koji.fedoraproject.org/koji/taskinfo?taskID=17847802

Comment 5 E.N. 2017-02-14 09:49:26 UTC
(In reply to Björn "besser82" Esser from comment #4)
> Build now fails for:
> 
> [snip]
> > configure: error: zlib library and headers are required
> [snip]

From the logs, for instance [1], you are using the R-3.3.2.tar.gz sources. Since that release, there have been a zlib bug fix :

* commit: https://github.com/wch/r-source/commit/a0fe05ce9d0937ad2334bb370785cb22c71e592b

* changelog: https://cran.r-project.org/doc/manuals/r-devel/NEWS.html
“INSTALLATION on a UNIX-ALIKE
The configure check for the zlib version is now robust to versions longer than 5 characters, including 1.2.10.
”

The relevant version is R-patched 3.3.2 [2]. You are maybe hitting that same zlib bug and building from the patched sources might be the right way to go.

----
[1] https://kojipkgs.fedoraproject.org//work/tasks/7841/17847841/build.log
[2] https://stat.ethz.ch/R/daily/R-patched.tar.gz

Comment 6 Björn 'besser82' Esser 2017-02-14 11:35:46 UTC
Thank you for the patch!  =)

Build should be finished soon…


Note You need to log in before you can comment on or make changes to this bug.