Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418481 - "remove key pair" should be disabled for keys that do not have permissions
Summary: "remove key pair" should be disabled for keys that do not have permissions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Julian Cheal
QA Contact: Shveta
URL:
Whiteboard: cloud:ec2
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 23:51 UTC by Shveta
Modified: 2019-04-25 17:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-25 17:55:41 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
remove key pair (202.24 KB, image/png)
2017-02-01 23:51 UTC, Shveta
no flags Details
detail screen (103.94 KB, image/png)
2017-02-06 03:08 UTC, Shveta
no flags Details

Description Shveta 2017-02-01 23:51:43 UTC
Created attachment 1246915 [details]
remove key pair

Description of problem:


Version-Release number of selected component (if applicable):
5.7.1.0.20170124142149_8a5f4d5 

How reproducible:


Steps to Reproduce:
1. Cloud ec2 keys are imported into CFME and is shown under Compute - cloud - key pair
2. Attempt to delete , shows message .
3. Remove key pair should be disabled for keys that cannot be deleted through CFME

Actual results:


Expected results:


Additional info:

Comment 2 Dave Johnson 2017-02-03 21:07:20 UTC
Removing RFE, if a button is enabled when its not supported, that is a bug.

Comment 4 Shveta 2017-02-06 03:08:30 UTC
Created attachment 1247932 [details]
detail screen

"remove key pair" is present in detail screen too.

Comment 6 Harpreet Kataria 2017-02-27 20:43:36 UTC
Greg,

It looks like we need support_feature mixin changes to return whether delete is available for selected KeyPair record or not.

~Harpreet

Comment 7 Julian Cheal 2018-04-26 11:32:04 UTC
What's a scenario when a key pair shouldn't be deleted?

Comment 8 Shveta 2018-05-14 16:20:05 UTC
Key pairs are imported from cloud providers .
User created key pair can be deleted but imported ones cannot be deleted from Cloudforms .
So the button "remove key pair from inventory" should be disabled.

Comment 9 Julian Cheal 2018-06-05 14:17:07 UTC
PR for this https://github.com/ManageIQ/manageiq-ui-classic/pull/4061. Is this the kind of action you were expecting Shveta?

Comment 10 Shveta 2018-06-05 16:40:21 UTC
Yes Julian ,Looks good .

Comment 11 Julian Cheal 2018-07-05 14:06:02 UTC
Hi Shveta,

Why is it that imported key pairs, i.e. ones created in AWS cannot be deleted in CF?

Does CF not then delete the key pair from AWS too?

Comment 12 Shveta 2018-07-10 15:30:18 UTC
Hi Julian , 

As of now the Key created in AWS cannot be deleted from CF.
Not sure if development plans to support that in the future .

Thanks, 
Shveta

Comment 13 Shveta 2019-04-03 22:08:55 UTC
Fixed in 5.10.3.0.20190402144650_62f3960


Note You need to log in before you can comment on or make changes to this bug.