Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 141849 - GFS-modules dependency problem when used with up2date
GFS-modules dependency problem when used with up2date
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Feist
GFS Bugs
Depends On:
  Show dependency treegraph
Reported: 2004-12-03 19:43 EST by Jos Vos
Modified: 2010-01-11 22:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-31 17:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2004-12-03 19:43:04 EST
Description of problem:

-  GFS-modules now provides kernel-modules (why?).

-  Up2date standard has "kernel-modules" in the list of

-  So up2date tries to keep the old GFS-modules-6.0.0-15.

-  But GFS-modules-6.0.0-15 requires GFS-6.0.0-15, that conflicts
   with the new GFS-6.0.2-12.

-  So up2date reports a dependency problems and does not update.

Version-Release number of selected component (if applicable):

How reproducible:
Use up2date with the standard configuration and try to update GFS and

Solution: GFS-modules should not provide kernel-modules, as this was
in earlier days used for the main kernel package with modules. 
Another solution could be to let the GFS-modules not require exact the
same version of GFS, although this is maybe not recommendable.
Comment 2 Chris Feist 2004-12-06 12:19:05 EST
We have to have the GFS-modules package provide kernel modules
otherwise an up2date could update the GFS-modules, but not the kernel
which could potentially cause problems.

I'm currently trying to find out the best way to handle updating GFS rpms.
Comment 3 Jos Vos 2004-12-06 12:46:34 EST
GFS-modules already *does* have a Requires: kernel = ..., so providing
kernel-modules does not help anything with *that*.

The problem is: GFS can only be upgraded (no multiple installs
possible), for GFS-modules you ideally want to be able to have
multiple versions installed (like the kernel), but GFS-modules
requires the exact same version of GFS.  Result: a serious dependency
problem :-(.

One of the solutions can be to have GFS-modules requires GFS >=
%{version} or so, if that's technically ok, so they are not completely
bound to each other.
Comment 4 Chris Feist 2004-12-06 16:18:39 EST
You're correct about the dependency problem.  I've fixed the Requires
for GFS-modules so they require a GFS rpm >= the GFS-modules rpm. 
This should fix the dependency problems you were having.

This fix is included in GFS-6.0.2-19
Comment 5 Jos Vos 2004-12-06 16:42:59 EST
I didn't test it, but I think it doesn't: the old GFS-modules still
requires the exact same version of GFS, and the new GFS-modules wants
the newer version of GFS, so these two GFS-modules can't be installed

I think the only solution now is to remove kernel-modules *and*
include the >= test for the first time, so that the next version of
GFS will work ok with kernel-modules added.
Comment 6 Chris Feist 2004-12-06 18:17:18 EST
If you upgrade to the two latest packages (GFS & GFS-modules) you will
be able to have multiple versions of the future GFS-modules installed.
 And you will not have a problem if up2date upgrades your GFS package.

Unfortunately there is no way to change the behavior of the old
package, but you should be able to do a rpm -Uvh of the new packages.
 (or bring them both down with up2date).
Comment 7 Jos Vos 2004-12-06 18:29:40 EST
The problem is that the "Provides: kernel-modules" and the default
setting of up2date (pkgsInstallNotUpdate) make it not possible to
upgrade to the GFS and GFS-modules combination via up2date (a rpm -Uvh
is possible).  But that's already a problem with the currently
released version (or didn't you release that yet - I only got the

As said, the best way is to first release a package with >= ... and
without kernel-modules, and add kernel-modules again in the version
after that.
Comment 8 Chris Feist 2005-05-31 17:29:52 EDT
The latest release version should fix this problem.

GFS-modules requires a version of GFS >= to the version of GFS-modules.

Note You need to log in before you can comment on or make changes to this bug.