Bug 1418541 - [Ganesha+SSL] : Bonnie++ hangs during rewrites.
Summary: [Ganesha+SSL] : Bonnie++ hangs during rewrites.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 3.10
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On: 1408576
Blocks: 1418213 1418539
TreeView+ depends on / blocked
 
Reported: 2017-02-02 04:11 UTC by Mohit Agrawal
Modified: 2017-03-06 17:44 UTC (History)
21 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1408576
Environment:
Last Closed: 2017-03-06 17:44:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-02-02 04:13:31 UTC
REVIEW: https://review.gluster.org/16513 (rpc/socket.c : Bonnie++ hangs during rewrites in ganesha + SSL) posted (#1) for review on release-3.10 by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 2 Worker Ant 2017-02-02 17:33:49 UTC
COMMIT: https://review.gluster.org/16513 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit db713127b7d2920ce98999143a502b6f554e9cff
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Wed Feb 1 15:17:51 2017 +0530

    rpc/socket.c : Bonnie++ hangs during rewrites in ganesha + SSL
    
    Problem: Bonnie++ rewrite operation hangs in ganesha + SSL environment
    
    Solution: Bonnie++ hangs during execution of rewrite operation in
              ganesha + SSL environment.It was hanged due to blocking on poll
              call in ssl_do because no POLLOUT event was getting on socket.
              Socket is not getting POLLOUT event because all other threads
              are waiting to get lock and lock is not released ssl_do
              because it is not getting any event on poll.To correct it
              update the condition in ssl_do as same in getting error
              SSL_ERROR_WANT_READ.
    
    Test:     To test the patch followed below procedure
              1) Setup 2X2 Ganesha + SSL environment.
              2) Run bonnie from 3 nfs client parallely
              3) After run "Rewwrite operation" by bonnie it is hanged.
              4) After apply the patch it is not hanged.
    
    > BUG: 1418213
    > Change-Id: I5985cbbc4cfdac5d287268d791e31c274abc3c8d
    > Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    > Reviewed-on: https://review.gluster.org/16501
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    > (cherry picked from commit d7077bca4b372a056d23416294e729637e9af94e)
    
    Change-Id: Id029c71382025477bb5ff31f28ec537e4fe58b03
    BUG: 1418541
    Reviewed-on: https://review.gluster.org/16513
    Tested-by: MOHIT AGRAWAL <moagrawa@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 3 Shyamsundar 2017-03-06 17:44:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.