Bug 1418542 - Multiple smoke failures observed since yesterday
Summary: Multiple smoke failures observed since yesterday
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 04:19 UTC by Atin Mukherjee
Modified: 2017-02-02 07:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 07:35:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2017-02-02 04:19:33 UTC
Description of problem:

https://build.gluster.org/job/devrpm-el7/3055/console

07:13:33 Triggered by Gerrit: https://review.gluster.org/16502
07:13:33 Building remotely on slave25.cloud.gluster.org (smoke_tests rackspace_regression_2gb glusterfs-devrpms) in workspace /home/jenkins/root/workspace/devrpm-el7
07:13:33 Wiping out workspace first.
07:13:34 java.io.IOException: remote file operation failed: /home/jenkins/root/workspace/devrpm-el7 at hudson.remoting.Channel@148e532:slave25.cloud.gluster.org: java.nio.file.AccessDeniedException: /home/jenkins/root/workspace/devrpm-el7/RPMS/el7/x86_64/build.log
07:13:34 	at hudson.FilePath.act(FilePath.java:986)
07:13:34 	at hudson.FilePath.act(FilePath.java:968)
07:13:34 	at hudson.FilePath.deleteContents(FilePath.java:1183)
07:13:34 	at hudson.plugins.git.extensions.impl.WipeWorkspace.beforeCheckout(WipeWorkspace.java:28)
07:13:34 	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1094)
07:13:34 	at hudson.scm.SCM.checkout(SCM.java:485)
07:13:34 	at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
07:13:34 	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:607)
07:13:34 	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
07:13:34 	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
07:13:34 	at hudson.model.Run.execute(Run.java:1738)
07:13:34 	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
07:13:34 	at hudson.model.ResourceController.execute(ResourceController.java:98)
07:13:34 	at hudson.model.Executor.run(Executor.java:410)
07:13:34 Caused by: java.nio.file.AccessDeniedException: /home/jenkins/root/workspace/devrpm-el7/RPMS/el7/x86_64/build.log
07:13:34 	at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84)
07:13:34 	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
07:13:34 	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
07:13:34 	at sun.nio.fs.UnixFileSystemProvider.implDelete(UnixFileSystemProvider.java:244)
07:13:34 	at sun.nio.fs.AbstractFileSystemProvider.delete(AbstractFileSystemProvider.java:103)
07:13:34 	at java.nio.file.Files.delete(Files.java:1079)
07:13:34 	at sun.reflect.GeneratedMethodAccessor64.invoke(Unknown Source)
07:13:34 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
07:13:34 	at java.lang.reflect.Method.invoke(Method.java:606)
07:13:34 	at hudson.Util.deleteFile(Util.java:255)
07:13:34 	at hudson.FilePath.deleteRecursive(FilePath.java:1203)
07:13:34 	at hudson.FilePath.deleteContentsRecursive(FilePath.java:1212)
07:13:34 	at hudson.FilePath.deleteRecursive(FilePath.java:1194)
07:13:34 	at hudson.FilePath.deleteContentsRecursive(FilePath.java:1212)
07:13:34 	at hudson.FilePath.deleteRecursive(FilePath.java:1194)
07:13:34 	at hudson.FilePath.deleteContentsRecursive(FilePath.java:1212)
07:13:34 	at hudson.FilePath.deleteRecursive(FilePath.java:1194)
07:13:34 	at hudson.FilePath.deleteContentsRecursive(FilePath.java:1212)
07:13:34 	at hudson.FilePath.access$1100(FilePath.java:190)
07:13:34 	at hudson.FilePath$15.invoke(FilePath.java:1186)
07:13:34 	at hudson.FilePath$15.invoke(FilePath.java:1183)
07:13:34 	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2719)
07:13:34 	at hudson.remoting.UserRequest.perform(UserRequest.java:120)
07:13:34 	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
07:13:34 	at hudson.remoting.Request$2.run(Request.java:332)
07:13:34 	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
07:13:34 	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
07:13:34 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
07:13:34 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
07:13:34 	at java.lang.Thread.run(Thread.java:745)
07:13:34 	at ......remote call to slave25.cloud.gluster.org(Native Method)
07:13:34 	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
07:13:34 	at hudson.remoting.UserResponse.retrieve(UserRequest.java:220)
07:13:34 	at hudson.remoting.Channel.call(Channel.java:781)
07:13:34 	at hudson.FilePath.act(FilePath.java:979)
07:13:34 	... 13 more
07:13:34 Archiving artifacts
07:13:37 Finished: FAILURE

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nigel Babu 2017-02-02 07:35:04 UTC
Fixed. Post-mortem here: http://lists.gluster.org/pipermail/gluster-infra/2017-February/003153.html


Note You need to log in before you can comment on or make changes to this bug.