Bug 1418572 - Review Request: compat-libwebp05 - Compat package with libwebp 0.5 libraries
Summary: Review Request: compat-libwebp05 - Compat package with libwebp 0.5 libraries
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Yanko Kaneti
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 07:47 UTC by Kalev Lember
Modified: 2017-02-02 14:56 UTC (History)
2 users (show)

Fixed In Version: compat-libwebp05-0.5.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 14:56:02 UTC
Type: ---
yaneti: fedora-review+


Attachments (Terms of Use)

Description Kalev Lember 2017-02-02 07:47:55 UTC
Spec URL: https://kalev.fedorapeople.org/compat-libwebp05.spec
SRPM URL: https://kalev.fedorapeople.org/compat-libwebp05-0.5.2-1.fc26.src.rpm
Description:
Compatibility package with libwebp 0.5 librarires.

Fedora Account System Username: kalev

Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=17546698

This is a compat package to keep providing old libwebp library ABI after libwebp 0.6.0 soname bump in rawhide/F26. The changes to the libwebp package have been kept minimal in order to make it easy to port patches between F25 libwebp 0.5.2 and F26 compat-libwebp05 0.5.2 packages. Here's a full diff between the two: http://paste.fedoraproject.org/542715/

Background info: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/GPZ2KFALIYOXBFC46HVF63HNDXGLUKAN/

Comment 1 Yanko Kaneti 2017-02-02 08:14:32 UTC
Rubberstamp FTW

Comment 2 Kalev Lember 2017-02-02 08:22:26 UTC
Thanks Yanko!

Comment 3 Gwyn Ciesla 2017-02-02 14:36:46 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/compat-libwebp05

Comment 4 Kalev Lember 2017-02-02 14:56:02 UTC
Package imported and built.


Note You need to log in before you can comment on or make changes to this bug.