Bug 1418598 - Allow WWN to be specified when creating storage objects
Summary: Allow WWN to be specified when creating storage objects
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: targetcli
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks: 1388569
TreeView+ depends on / blocked
 
Reported: 2017-02-02 10:02 UTC by Prasanna Kumar Kalever
Modified: 2017-08-01 20:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:54:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2031 0 normal SHIPPED_LIVE targetcli, python-configshell, python-rtslib bug fix and enhancement update 2017-08-01 18:34:25 UTC

Description Prasanna Kumar Kalever 2017-02-02 10:02:27 UTC
Description of problem:

rtslib's API supports passing in the WWN for a new storage object, but up until now targetcli's "create" commands have not had this as an option Add this.

This will make it easier to configure things like multipath, which uses wwn to know if different block devices actually refer to the same underlying storage.


Version-Release number of selected component (if applicable):
targetcli 2.1.fb41-3.el7

Comment 4 Martin Hoyer 2017-04-28 13:22:07 UTC
Tested with:
targetcli-2.1.fb46-1.el7
python-rtslib-2.1.fb63-1.el7
python-configshell-1.1.fb23-1.el7
Works well. No regression found.

Comment 5 errata-xmlrpc 2017-08-01 20:54:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2031


Note You need to log in before you can comment on or make changes to this bug.