Bug 1418604 - Date and Time spoke does not allow the "Network Time" toggle to be turned on before networking is enabled, but has no feedback
Summary: Date and Time spoke does not allow the "Network Time" toggle to be turned on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: alpha
: 7.4
Assignee: Vendula Poncova
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-02-02 10:27 UTC by SATHEESARAN
Modified: 2017-08-01 08:55 UTC (History)
8 users (show)

Fixed In Version: anaconda-21.48.22.115-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 08:55:41 UTC


Attachments (Terms of Use)
Date-Time configuration window showing up 'Network Time' (371.40 KB, image/png)
2017-02-02 10:31 UTC, SATHEESARAN
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2293 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC

Description SATHEESARAN 2017-02-02 10:27:16 UTC
Description of problem:
-----------------------
While installation of RHV-H NG node, I could see 'Date & Time' in the installer screen, when going in to configure 'Date & Time', I could see on top right, there is toggle to enable 'Network Time'. When turning it on, it again toggles to 'off'

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHV-H NG node - RHVH-4.1-20170127.0-RHVH-x86_64-dvd1.iso   

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Boot from RHV-H NG ISO ( ISO had RHEL 7 as base )
2. On the installer window, select 'Date & Time'
3. On the top right, there is 'Network Time', try to make it to 'ON'

Actual results:
---------------
'Network Time' never gets to 'ON', toggles back to 'OFF'

Expected results:
-----------------
When turning on 'Network Time', should enable NTP right at the installation time


Additional info:

Comment 1 SATHEESARAN 2017-02-02 10:31:21 UTC
Created attachment 1247047 [details]
Date-Time configuration window showing up 'Network Time'

Comment 2 Ryan Barry 2017-02-02 14:07:19 UTC
This works if Networking is configured first.

Anaconda should either disable the toggle or provide meaningful feedback if networking is not configured.

Comment 4 Rui Matos 2017-04-18 15:14:31 UTC
I just hit this with today's nightly build. The installation source spoke also doesn't display any feedback about why the URL method is grayed out.

Comment 5 Vendula Poncova 2017-05-17 10:36:34 UTC
We cannot disable the toggle or prevent it to slide to ON before we set it back to OFF, so we will just provide a warning message. We will show a message in the installation source spoke as well.

The fix is available in a pull request:
https://github.com/rhinstaller/anaconda/pull/1062

Comment 8 Peter Kotvan 2017-05-29 07:37:59 UTC
I was able to reproduce this bug on RHEL-7.3 GA and verify the fix on RHEL-7.4-20170525.7 with anaconda-21.48.22.115-1.el7.

Comment 9 errata-xmlrpc 2017-08-01 08:55:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.