Bug 1418669 - spam of "INFO (jsonrpc/[0-9]) [jsonrpc.JsonRpcServer] RPC call" messages in vdsm.log
Summary: spam of "INFO (jsonrpc/[0-9]) [jsonrpc.JsonRpcServer] RPC call" messages in ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: 4.19.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.1
: ---
Assignee: Piotr Kliczewski
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 13:26 UTC by Jiri Belka
Modified: 2017-02-03 17:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-03 17:27:07 UTC
oVirt Team: Infra
rule-engine: ovirt-4.1+


Attachments (Terms of Use)

Description Jiri Belka 2017-02-02 13:26:12 UTC
Description of problem:

it seems jsonrpc is little bit spammy and i'm not sure the content of this INFO-level messages are interesting for "end-user" (eg. sysadmin).

so in cca 5 hours i got 1331 such messages in log.

[root@dell-r210ii-13 ~]# awk 'NR == 1 { print $1,$2 }' /var/log/vdsm/vdsm.log
Thread-12::DEBUG::2017-02-02 09:01:08,065::check::296::storage.check::(_start_process)
[root@dell-r210ii-13 ~]# awk 'END { print $1,$2 }' /var/log/vdsm/vdsm.log
2017-02-02 14:19:11,286
[root@dell-r210ii-13 ~]# egrep -c 'INFO  \(jsonrpc/[0-9]\) \[jsonrpc\.JsonRpcServer\] RPC call' /var/log/vdsm/vdsm.log
1331
[root@dell-r210ii-13 ~]# egrep 'INFO  \(jsonrpc/[0-9]\) \[jsonrpc\.JsonRpcServer\] RPC call' /var/log/vdsm/vdsm.log | tail
2017-02-02 14:18:42,916 INFO  (jsonrpc/5) [jsonrpc.JsonRpcServer] RPC call Host.getAllVmStats succeeded in 0.00 seconds (__init__:515)
2017-02-02 14:18:55,152 INFO  (jsonrpc/6) [jsonrpc.JsonRpcServer] RPC call Host.getStats succeeded in 0.01 seconds (__init__:515)
2017-02-02 14:18:57,122 INFO  (jsonrpc/7) [jsonrpc.JsonRpcServer] RPC call Host.getAllVmStats succeeded in 0.00 seconds (__init__:515)
2017-02-02 14:18:58,923 INFO  (jsonrpc/0) [jsonrpc.JsonRpcServer] RPC call Host.getAllVmStats succeeded in 0.00 seconds (__init__:515)
2017-02-02 14:19:11,286 INFO  (jsonrpc/2) [jsonrpc.JsonRpcServer] RPC call Host.getStats succeeded in 0.00 seconds (__init__:515)
2017-02-02 14:19:12,139 INFO  (jsonrpc/1) [jsonrpc.JsonRpcServer] RPC call Host.getAllVmStats succeeded in 0.00 seconds (__init__:515)
2017-02-02 14:19:14,929 INFO  (jsonrpc/3) [jsonrpc.JsonRpcServer] RPC call Host.getAllVmStats succeeded in 0.00 seconds (__init__:515)
2017-02-02 14:19:26,693 INFO  (jsonrpc/4) [jsonrpc.JsonRpcServer] RPC call Host.getStats succeeded in 0.01 seconds (__init__:515)
2017-02-02 14:19:27,158 INFO  (jsonrpc/5) [jsonrpc.JsonRpcServer] RPC call Host.getAllVmStats succeeded in 0.00 seconds (__init__:515)
2017-02-02 14:19:30,936 INFO  (jsonrpc/6) [jsonrpc.JsonRpcServer] RPC call Host.getAllVmStats succeeded in 0.00 seconds (__init__:515)
[root@dell-r210ii-13 ~]# rpm -q vdsm
vdsm-4.19.4-1.el7ev.x86_64


Version-Release number of selected component (if applicable):
vdsm-4.19.4-1.el7ev.x86_64

How reproducible:
1 in 1

Steps to Reproduce:
1. just happens with this vdsm version
2.
3.

Actual results:
vdsm.log is spammed with jsonrpc messages

Expected results:
imo INFO level messages should be somehow end-user readable and of his interest

Additional info:
this host is connected to 4.0 engine right now, 4.0.6.3-0.1.el7ev

Comment 2 Michal Skrivanek 2017-02-03 07:57:41 UTC
What do you plan to do with it? IMO this is intentional, readable, and reflects reality, I wouldn't change anything

Comment 3 Piotr Kliczewski 2017-02-03 15:47:48 UTC
In my opinion those are very important messages so it is easier to understand what is happening in vdsm. For me it is not a bug.


Note You need to log in before you can comment on or make changes to this bug.