Bug 141867 - weirdness with usb dvd burner after burning disks
weirdness with usb dvd burner after burning disks
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-12-04 04:46 EST by Chris Petersen
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-15 19:03:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Petersen 2004-12-04 04:46:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:
kernel: 2.6.9-1.681_FC3smp

I wasn't sure whether to file this under cdrtools, dvdrtools or kernel
(since it's related to all of them).  Basically, I have an external
usb2 dvd burner, and I use a script that basically calls mkisofs and
cdrecord to burn the disk (I've tried by hand, too).  The dvd burner
shows up as /dev/scd0 (/media/cdrecorder1) and I am able to
successfully burn disks (I've verified this).  However, once I've
burnt a disk, /dev/scd0 becomes unusable.  Sometimes this means I just
can't mount anything (always comes up as "bad superblock"), or
sometimes /dev/scd0 just disappears, such that if I power the burner
off/on, it's re-detected as /dev/scd1, even though /dev/scd0 doesn't
exist (and it still won't mount disks).

I've tried this with the UP kernel, too, and get the same errors (with
the addition that the system will hang during shutdown/reboot
somewhere near the very end of things).

Rebooting solves the problem until I burn another disk.

Version-Release number of selected component (if applicable):

How reproducible:

Additional info:

I believe that this is somehow related to a previous bug that I had
open at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123876 --
that bug went away, eventually, although I still had trouble burning
disks with SMP kernels (cdrecord couldn't figure out how to enable
burnfree, and no matter how slow I burned, I'd get buffer underruns).
Comment 1 Dave Jones 2005-07-15 13:44:12 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Chris Petersen 2005-07-15 17:39:18 EDT
sorry, don't have my usb burner anymore.  had to install it internally so I
could actually use it.  Hopefully someone else can verify this.
Comment 3 Dave Jones 2005-07-15 19:03:32 EDT
I'll close this out for now. If someone else has the same problem, typically
they file a new bug anyway.

Thanks anyway.

Note You need to log in before you can comment on or make changes to this bug.