Bug 1418680 - Remove Interface from Router throws Unexpected error
Summary: Remove Interface from Router throws Unexpected error
Keywords:
Status: CLOSED DUPLICATE of bug 1413212
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Greg Blomquist
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 14:01 UTC by Ido Ovadia
Modified: 2017-02-07 04:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 14:27:41 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)

Description Ido Ovadia 2017-02-02 14:01:40 UTC
Description of problem:
=======================
I created a router and connect it to external gateway and internal network
Click "Remove Interface from this Router" throws "Unexpected error encountered"

Version-Release number of selected component:
=============================================
5.7.1.0.20170124142149_8a5f4d5

How reproducible:
=================
100%

Steps to Reproduce:
====================
Note: I have attached the interface to the router via OpenStack CLI due to https://bugzilla.redhat.com/show_bug.cgi?id=1413212

1. Create a router on overcloud
2. Set a gateway 
3. Add an internal network to the router
4. From CFME: Click Configuration --> "Remove Interface from this Router"

Actual results:
===============
Unexpected error encountered

Error text:

undefined local variable or method `checked_item_id' for #<NetworkRouterController:0x00000012178b50> Did you mean? checked_router_id [network_router/button]

Comment 1 Tzu-Mainn Chen 2017-02-02 14:27:41 UTC
This is a duplicate of an issue raised in https://bugzilla.redhat.com/show_bug.cgi?id=1413212

*** This bug has been marked as a duplicate of bug 1413212 ***


Note You need to log in before you can comment on or make changes to this bug.