Bug 1418686 - Copy of license is missing for the package rusers
Summary: Copy of license is missing for the package rusers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rusers
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Kubat
QA Contact: Vaclav Danek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 14:18 UTC by Vaclav Danek
Modified: 2017-08-01 12:20 UTC (History)
3 users (show)

Fixed In Version: rusers-0.17-81.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 12:20:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1907 normal SHIPPED_LIVE rusers bug fix update 2017-08-01 16:04:31 UTC

Description Vaclav Danek 2017-02-02 14:18:03 UTC
Description of problem:
Copy of license is missing in packages for rusers

Version-Release number of selected component (if applicable):
rusers-0.17-80.el7.x86_64
rusers-server-0.17-80.el7.x86_64
rusers-debuginfo-0.17-80.el7.x86_64

How reproducible:
Check /usr/share/doc/rusers-0.17 for any license information.

Actual results:
License is missing.

Expected results:
License is present.

Additional info:

Comment 1 Petr Kubat 2017-02-02 14:35:09 UTC
The source code seems is licensed under a 3-clause BSD license and there has been an explicit re-licensing of rstat_proc.c in the past:
http://pkgs.devel.redhat.com/cgit/rpms/rusers/commit/?h=rhel-7.4&id=ac4eac54eb1fde26857c4654af1bf428d2a04860

The .spec file also says it should be licensed under BSD.
Setting needinfo on hhorak to check if that is really the case (and for devel-ack).

Comment 2 Honza Horak 2017-02-14 12:42:54 UTC
Yes, I believe BSD should be used.

Comment 5 Vaclav Danek 2017-02-22 09:11:32 UTC
BSD 3-clause licence is present in:
/usr/share/doc/rusers-server-0.17/COPYING
/usr/share/doc/rusers-0.17/COPYING
=> Verified

Comment 6 errata-xmlrpc 2017-08-01 12:20:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1907


Note You need to log in before you can comment on or make changes to this bug.