Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418709 - Deleting a Router which has port in use should throw an error
Summary: Deleting a Router which has port in use should throw an error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Marek Aufart
QA Contact: Ido Ovadia
URL:
Whiteboard: openstack
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 14:53 UTC by Ido Ovadia
Modified: 2018-10-02 14:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-02 14:30:36 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)

Description Ido Ovadia 2017-02-02 14:53:55 UTC
Description of problem:
=======================
Deleting a Router which has port in use is not allowed and should throw an error
but CFME message: "Delete initiated for 1 Network Router".

Version-Release number of selected component:
=============================================
5.7.1.0.20170124142149_8a5f4d5

How reproducible:
=================
100%

Steps to Reproduce:
===================
Note: I have attached the interface to the router via OpenStack CLI due to https://bugzilla.redhat.com/show_bug.cgi?id=1413212

1. Create a router on overcloud
2. Set a gateway 
3. Add an internal network to the router
4. From CFME: Click Configuration --> Delete this Router 

Actual results:
===============
CFME message: "Delete initiated for 1 Network Router."
but router does not deleted (-this is correct action)

Expected results:
=================
Error massage like:
"Error: Unable to delete router "Router <router name or ID> still has ports in use"

Comment 1 Tzu-Mainn Chen 2017-04-12 15:45:14 UTC
This is difficult, because the MIQ way of doing things is to create a task for an action, and have the task report back.  Right now you can see the status of the task in the tasks UI; maybe it makes sense to investigate whether tasks can start pushing notifications into the UI?

Comment 2 Josh Carter 2018-10-02 14:30:36 UTC
Dear customer, 

The CloudForms team is reviewing the current CloudForms Bug(defect) backlog in order to target engineering efforts. We are closing any bugs for versions that no longer have an active errata stream or that have hit their age limit. We are committing to better management of the backlog as we move forward. If you have an bug that you are still able to reproduce on a current version of CloudForms please open a new bug. 

If you have any concerns about this, please let us know.

Thanks and regards!

Comment 3 Josh Carter 2018-10-02 14:33:03 UTC
Dear customer, 

The CloudForms team is reviewing the current CloudForms Bug(defect) backlog in order to target engineering efforts. We are closing any bugs for versions that no longer have an active errata stream or that have hit their age limit. We are committing to better management of the backlog as we move forward. If you have an bug that you are still able to reproduce on a current version of CloudForms please open a new bug. 

If you have any concerns about this, please let us know.

Thanks and regards!


Note You need to log in before you can comment on or make changes to this bug.