Bug 141871 - Keyboard layout switches back to US from SwissGerman
Keyboard layout switches back to US from SwissGerman
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-04 08:21 EST by C. Bourboulas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-17 04:36:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C. Bourboulas 2004-12-04 08:21:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Everytime after I booted or logged out an in again, the keyboard
layout of my notebook is set back to US (for instance z / y
exchanged). I then have to go to System Settings > Keyboard to switch
back to the intended Swiss German layout. Interestingly, 'Swiss
German' is already selected, a simple [OK] turns the trick - which
alas only lasts as long as the session.

more /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="sg"


Version-Release number of selected component (if applicable):
kbd-1.12-2

How reproducible:
Always

Steps to Reproduce:
1. Wet you keyboard layout to Swiss German in System Settings / Keyboard.
2. See, whether your keyboard show letters accordingly ie. for a US
Keyboard, a Y should produce a Z.
3. Log out and log in
4. See, whether 2. still is true.
    

Actual Results:  A 'Y' is shown on any program capable of typing in it.

Expected Results:  A 'Z' is displayed instead.

Additional info:
Comment 1 C. Bourboulas 2004-12-09 10:40:15 EST
Update
I found another, probably related error:

I tried to have a shorter workaround to the problem by including the
keyboard indicator in the panel. I then tried to add 'Swiss German'
via the 'Keyboard Preferences' Screen of the indicator, wich raised
following error:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60801000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
-------------------- result is -----------------------------------
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "de_CH", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""
---------------------- end ----------------------------------------

- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
-------------------- result is ------------------------------------
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
 update_handlers = []
Comment 2 Miloslav Trmač 2005-02-19 15:12:54 EST
Hello,
This is all related to keyboard layout in X, not on the console, right?
Comment 3 Miloslav Trmač 2005-04-17 04:36:27 EDT
Please reopen this report if you can provide the requested data.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.