Bug 1418744 - podfying cfme: cfme "Container Statuses Summary" table is not reporting the same info as in "Last State" in
Summary: podfying cfme: cfme "Container Statuses Summary" table is not reporting the s...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Federico Simoncelli
QA Contact: Dafna Ron
URL:
Whiteboard: container:pod
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 15:44 UTC by Dafna Ron
Modified: 2017-02-07 04:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 17:39:49 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)
screenshot (210.08 KB, image/png)
2017-02-02 15:44 UTC, Dafna Ron
no flags Details

Description Dafna Ron 2017-02-02 15:44:32 UTC
Created attachment 1247144 [details]
screenshot

Description of problem:

I was looking at the cfme pod Container Statuses Summary and there is no indication the pod has previously been terminated but when I run oc describe on the pod there is a previous termination reported. 

I suspect that the reason we do not see the info is because this pod has been terminated before the provider has been added but cfme pod has to be running before we can add the provider. 

Version-Release number of selected component (if applicable):

cfme-5.7.1.0-2.el7cf.x86_64

How reproducible:


Steps to Reproduce:
1. deploy cfme pod -> re-schedule/re-deploy the pod -> add the openshift as a container provider in the pod 
2. login to webadmin -> navigate to pods -> select pod
3. on the openshift provider run 'oc describe <pod>
4. look at the table named "Container Statuses Summary"

Actual results:

in openshift we can see the pod has been previously terminated but in cfme the pod is reported with 0 termination 

Expected results:

we should see the same info. 

Additional info: screen shot attached

NAME                 READY     STATUS    RESTARTS   AGE
cloudforms-1-2xdsx   1/1       Running   4          6d
memcached-1-yfu12    1/1       Running   0          6d
postgresql-1-0ckis   1/1       Running   0          6d
[root@dafna-openshift-master01 ~]# oc describe pods cloudforms-1-2xdsx
Name:			cloudforms-1-2xdsx
Namespace:		dafna-test
Security Policy:	privileged
Node:			dafna-openshift-node01.qa.lab.tlv.redhat.com/10.35.97.112
Start Time:		Fri, 27 Jan 2017 14:06:50 +0200
Labels:			app=cloudforms
			deployment=cloudforms-1
			deploymentconfig=cloudforms
			name=cloudforms
Status:			Running
IP:			10.128.0.67
Controllers:		ReplicationController/cloudforms-1
Containers:
  cloudforms:
    Container ID:	docker://64f1da7f1a4385669a3fb9b5b33f8901fbef8e693f954766306775b381818d7f
    Image:		brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/cloudforms/cfme-openshift-app@sha256:693b7a3cb4dba5b54b8b3369e9f3c7b6ae398067bb2e0c4c2a0e4e8fdb9e91e9
    Image ID:		docker-pullable://brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/cloudforms/cfme-openshift-app@sha256:693b7a3cb4dba5b54b8b3369e9f3c7b6ae398067bb2e0c4c2a0e4e8fdb9e91e9
    Ports:		80/TCP, 443/TCP
    Requests:
      memory:		4Gi
    State:		Running
      Started:		Mon, 30 Jan 2017 19:07:36 +0200
    Last State:		Terminated
      Reason:		Error
      Exit Code:	137
      Started:		Mon, 30 Jan 2017 17:51:33 +0200
      Finished:		Mon, 30 Jan 2017 19:07:34 +0200
    Ready:		True
    Restart Count:	4
    Liveness:		http-get http://:80/ delay=480s timeout=3s period=10s #success=1 #failure=3
    Readiness:		http-get http://:80/ delay=200s timeout=3s period=10s #success=1 #failure=3
    Volume Mounts:
      /persistent from cfme-app-volume (rw)
      /var/run/secrets/kubernetes.io/serviceaccount from default-token-sc3e4 (ro)
    Environment Variables:
      APPLICATION_INIT_DELAY:		30
      DATABASE_SERVICE_NAME:		postgresql
      DATABASE_REGION:			0
      MEMCACHED_SERVICE_NAME:		memcached
      POSTGRESQL_USER:			root
      POSTGRESQL_PASSWORD:		smartvm
      POSTGRESQL_DATABASE:		vmdb_production
      POSTGRESQL_MAX_CONNECTIONS:	100
      POSTGRESQL_SHARED_BUFFERS:	64MB
Conditions:
  Type		Status
  Initialized 	True 
  Ready 	True 
  PodScheduled 	True 
Volumes:
  cfme-app-volume:
    Type:	PersistentVolumeClaim (a reference to a PersistentVolumeClaim in the same namespace)
    ClaimName:	cloudforms
    ReadOnly:	false
  default-token-sc3e4:
    Type:	Secret (a volume populated by a Secret)
    SecretName:	default-token-sc3e4
QoS Class:	Burstable
Tolerations:	<none>
No events.
[root@dafna-openshift-master01 ~]#

Comment 1 Federico Simoncelli 2017-02-06 17:39:49 UTC
(In reply to Dafna Ron from comment #0)
> Created attachment 1247144 [details]
> screenshot
> 
> Description of problem:
> 
> I was looking at the cfme pod Container Statuses Summary and there is no
> indication the pod has previously been terminated but when I run oc describe
> on the pod there is a previous termination reported. 
> 
> I suspect that the reason we do not see the info is because this pod has
> been terminated before the provider has been added but cfme pod has to be
> running before we can add the provider. 


The Container Statuses Summary shows the number of Containers currently Waiting, Running and Terminated.

As you reported there is 1 Container Running and the screenshot is reporting 1 Container Running.

Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.