Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418746 - list of systems using proxy is not click-able and can not be added to SSM
Summary: list of systems using proxy is not click-able and can not be added to SSM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks: sat58-errata
TreeView+ depends on / blocked
 
Reported: 2017-02-02 15:51 UTC by Jan Hutař
Modified: 2017-10-19 11:57 UTC (History)
7 users (show)

Fixed In Version: spacewalk-java-2.5.14-96-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-19 11:57:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2915 0 normal SHIPPED_LIVE Red Hat Satellite 5.8.0 bug fix update 2017-10-19 15:56:50 UTC

Description Jan Hutař 2017-02-02 15:51:08 UTC
Description of problem:
List of systems using proxy (on system detail page -> Proxy) is not click-able.


Version-Release number of selected component (if applicable):
spacewalk-proxy-common-2.5.0-4.el6sat.noarch


How reproducible:
1 of 1


Steps to Reproduce:
1. Install Proxy using spacewalk-proxy-installer-2.5.0-7.el6sat
2. Register one system through that proxy
3. On Satellite webUI check Proxy's system profile detail -> Proxy


Actual results:
There is a list of systems registered using the proxy, but you can not click on the system (to get to its system profile details page) and also you can not check checkbox which allows you to add the system(s) to SSM.


Expected results:
Systems using proxy profile name should be link and there should be checkboxes allowing you to add the systems to the SSM.


Additional info:
This is regression compared to Satellite 5.7.0:

https://<sat570>/network/systems/details/proxy-clients.pxt?sid=1000109780;upper=1;filter_string=;lower=1;alphabar_column=NAME
vs.
https://<sat580>/rhn/systems/details/ProxyClients.do?sid=1000010108&

Comment 1 Tomas Lestach 2017-02-03 08:15:54 UTC
Can this be a duplicate of Bug 1408167?

Comment 2 Jan Hutař 2017-02-03 09:26:24 UTC
Again, you are right, 50% of duplicate.

Looking at https://github.com/spacewalkproject/spacewalk/commit/21829fd4896d49428e465b37ab240c9e892f5b0e it does not address "checkboxes allowing you to add the systems to the SSM".

Comment 3 Tomas Lestach 2017-02-03 10:28:01 UTC
Ack, thank you. Makes sense.

Comment 4 Gennadii Altukhov 2017-02-09 15:25:00 UTC
As was said in comment #1, half of this problem was solved in the BZ 1408167. The second half is fixed in upstream, spacewalk.git:
6202c4d2fef0bc2e73c610e130de83a91714d649

Comment 7 Pavel Studeník 2017-05-16 15:54:52 UTC
Verified spacewalk-java-2.5.14-84.el6sat.noarch

Go to page: /rhn/systems/details/ProxyClients.do?sid=<system_id>

Comment 8 Lukáš Hellebrandt 2017-06-12 14:00:37 UTC
FailedQE with spacewalk-java-2.5.14-89.

The systems are now indeed clickable.

However, the SSM checkbox doesn't behave correctly:

1) Go to the page with systems registered through proxy (Systems->Systems->Proxy-><select>->Proxy)
2) Select some system
3) Go to another page (e.g. Overview) and then go to Proxy (do NOT just refresh)
4) Notice that no checkbox is selected (but the system is still in SSM as you can see under the global search bar)

This is a regression.

Comment 10 Gennadii Altukhov 2017-06-19 14:28:02 UTC
The bug is fixed in upstream. spacewalk.git:
940a571ef24b78a258d106055c17181f68709001

Comment 16 errata-xmlrpc 2017-10-19 11:57:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2915


Note You need to log in before you can comment on or make changes to this bug.