Bug 1418751 - elasticsearch fails to start
Summary: elasticsearch fails to start
Keywords:
Status: CLOSED DUPLICATE of bug 1351504
Alias: None
Product: Fedora
Classification: Fedora
Component: elasticsearch
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 16:12 UTC by Gonéri Le Bouder
Modified: 2017-02-02 20:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 20:20:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Gonéri Le Bouder 2017-02-02 16:12:17 UTC
Description of problem:

Exception in thread "main" java.lang.NoClassDefFoundError: com/fasterxml/jackson/databind/JsonMappingException
	at com.fasterxml.jackson.dataformat.yaml.YAMLFactory._createParser(YAMLFactory.java:426)
	at com.fasterxml.jackson.dataformat.yaml.YAMLFactory.createParser(YAMLFactory.java:327)
	at org.elasticsearch.common.xcontent.yaml.YamlXContent.createParser(YamlXContent.java:90)
	at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:45)
	at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:46)
	at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:982)
	at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromUrl(ImmutableSettings.java:969)
	at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:95)
	at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:144)
	at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:215)
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)
Caused by: java.lang.ClassNotFoundException: com.fasterxml.jackson.databind.JsonMappingException
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 11 more


Version-Release number of selected component (if applicable):

elasticsearch-1.7.1-3.fc24.noarch

How reproducible:

Install and Start elasticsearch manually or as a service.

Comment 1 Gonéri Le Bouder 2017-02-02 20:20:48 UTC

*** This bug has been marked as a duplicate of bug 1351504 ***


Note You need to log in before you can comment on or make changes to this bug.