Bug 1418780 - provision of catalog bundles made of several azure ressources
Summary: provision of catalog bundles made of several azure ressources
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.7.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Bill Wei
QA Contact: Dave Johnson
URL:
Whiteboard: service:azure:provision
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 17:09 UTC by Felix Dewaleyne
Modified: 2020-04-15 15:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-02 14:31:52 UTC
Category: ---
Cloudforms Team: Azure
Target Upstream Version:


Attachments (Terms of Use)

Description Felix Dewaleyne 2017-02-02 17:09:41 UTC
Description of problem:
trying to provision twoazure rssources as part of a catalog bundle ensues in irregular behaviour

Version-Release number of selected component (if applicable):
5.6.3.3

How reproducible:
varies

Steps to Reproduce:
1.set up a service bundle of two azure ressources
2.set up a dialog that will customize th ressources (different stack names, etc) based on instructions from https://pemcg.gitbooks.io/mastering-automation-in-cloudforms-and-manageiq/content/chapter34.html
3. provision the bundle

Actual results:
the bundle will have 1 or 0 of the vms provisioned

Expected results:
the ressources are provisioned with a consistent behaviour

Additional info:
refresh issues against azure were found at first but after resolving them the isue still persists.  sometimes vms provisioned are also attached to other sruns of the service bundle, as described by the customer.

Comment 4 Jeff Teehan 2017-02-09 18:09:45 UTC
I've already verified that it doesn't work.  I think this is a clone, or possibly dupe of the 5.7.1 bug.  Here is the RFE bz:

https://bugzilla.redhat.com/show_bug.cgi?id=1372150

It can't work because the bundle has no provision for selecting a provider and passing that to the bundled items.

Anyway, 10.16.6.247 has 5.6.4 on it and it's all setup if you want to use that.

Comment 5 Greg McCullough 2017-02-09 23:11:20 UTC
Jeff - I do think the referenced RFE is the same.  That one deals with adding the same exact service item multiple times to a single service bundle.  That is not supported at the moment.  But you could create two similar service items (both azure provisions) and connect them to a bundle.

Felix:
Are the Azure Service items here using orchestration templates or image provisioning?

Which catalog bundle should we be looking into on your test appliance?

Comment 6 Jeff Teehan 2017-02-10 00:01:25 UTC
I did try that in my testing and it just didn't work.  It's set up on https://10.16.7.73 if you want to look.  For whatever reason, the data from the provider is not propagating up to the Bundle.  Mine uses orchestration templates.
AzureAdd1, AzureAdd2, and the bundle is AzureAddMulti

Comment 12 Josh Carter 2018-10-02 14:31:52 UTC
Dear customer, 

The CloudForms team is reviewing the current CloudForms Bug(defect) backlog in order to target engineering efforts. We are closing any bugs for versions that no longer have an active errata stream or that have hit their age limit. We are committing to better management of the backlog as we move forward. If you have an bug that you are still able to reproduce on a current version of CloudForms please open a new bug. 

If you have any concerns about this, please let us know.

Thanks and regards!

Comment 13 Josh Carter 2018-10-02 14:34:15 UTC
Dear customer, 

The CloudForms team is reviewing the current CloudForms Bug(defect) backlog in order to target engineering efforts. We are closing any bugs for versions that no longer have an active errata stream or that have hit their age limit. We are committing to better management of the backlog as we move forward. If you have an bug that you are still able to reproduce on a current version of CloudForms please open a new bug. 

If you have any concerns about this, please let us know.

Thanks and regards!


Note You need to log in before you can comment on or make changes to this bug.