Bug 1418782
| Summary: | rhosp-director: Undercloud deployment fails with: Error: /Stage[main]/Nova::Db::Sync/Exec[nova-db-sync]/returns: change from notrun to 0 failed: Command exceeded timeout | ||||||||
|---|---|---|---|---|---|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Alexander Chuzhoy <sasha> | ||||||
| Component: | puppet-tripleo | Assignee: | Angus Thomas <athomas> | ||||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Omri Hochman <ohochman> | ||||||
| Severity: | high | Docs Contact: | |||||||
| Priority: | urgent | ||||||||
| Version: | 11.0 (Ocata) | CC: | aschultz, dbecker, emacchi, jjoyce, jschluet, mburns, mcornea, morazi, ohochman, rhel-osp-director-maint, slinaber, tvignaud, yprokule | ||||||
| Target Milestone: | ga | ||||||||
| Target Release: | 11.0 (Ocata) | ||||||||
| Hardware: | Unspecified | ||||||||
| OS: | Unspecified | ||||||||
| Whiteboard: | |||||||||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |||||||
| Doc Text: | Story Points: | --- | |||||||
| Clone Of: | Environment: | ||||||||
| Last Closed: | 2017-02-28 20:45:20 UTC | Type: | Bug | ||||||
| Regression: | --- | Mount Type: | --- | ||||||
| Documentation: | --- | CRM: | |||||||
| Verified Versions: | Category: | --- | |||||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||
| Embargoed: | |||||||||
| Attachments: |
|
||||||||
|
Description
Alexander Chuzhoy
2017-02-02 17:21:58 UTC
Created attachment 1247162 [details]
install-undercloud.log
Created attachment 1247163 [details]
sosreport from the undercloud node
Was able to workaround the reported issue with: sudo sed -i 's/^innodb_file_per_table.*//' /etc/my.cnf.d/galera.cnf sudo systemctl restart mariadb prior to running "openstack undercloud install" In reply to #3, that is only if you previously had run the install and did not have the following two patches https://review.openstack.org/#/c/428435/ and https://review.openstack.org/#/c/428843/ applied. Under normal cases, that doesn't fix the problem due to the setting being reapplied when the install process is run. reproduced on my bare-metal environment Omri, please provide software versions, logs, and hardware specs. If possible, providing access to the environment would also suffice. hi Alex - my issue got resolve using the workaround : sudo tee -a /usr/share/instack-undercloud/puppet-stack-config/puppet-stack-config.yaml.template <<'EOF' # https://bugzilla.redhat.com/show_bug.cgi?id=1418782 # NOTE(aschultz): raise upper limit on nova DB syncs for undercloud only. # There is no way this should take 15 minutes and if it does we now have way # different problems. But rather than block undercloud installs let's increase # the timeout for these actions. See LP#1661396 for more details. nova::db::sync::db_sync_timeout: 900 nova::db::sync_api::db_sync_timeout: 900 EOF |