Bug 1418792 - Entering wrong content provider credentials causes UI to never return
Summary: Entering wrong content provider credentials causes UI to never return
Keywords:
Status: NEW
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.1
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: John Matthews
QA Contact: Sudhir Mallamprabhakara
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 17:59 UTC by James Olin Oden
Modified: 2017-02-02 20:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description James Olin Oden 2017-02-02 17:59:50 UTC
Description of problem:
I was testing entering the wrong credentials in for the content provider.   The system was pointed to stage.   When I did this and clicked Next, the button changed to a grayed out "Logging in ..." text.   I waited 30 minutes and it never returned.   I tried to start another deployment, and when I got to the "Subscriptions:Content Provider" screen, what would be the Next button still was grayed out and said "Logging in ...".


Version-Release number of selected component (if applicable):
QCI-1.1-RHEL-7-20170201.t.0

How reproducible:
Only tried it once right after installation.   Could not get it to get out
of that state so I could not try again.

Steps to Reproduce:
1.   Create deployment and enter the wrong credentials for the content provider.

Actual results:
It "hung" as described above.

Expected results:
In a reaonsable amount of time an error should be displayed.


Note You need to log in before you can comment on or make changes to this bug.