Bug 1418793 - Wayland creating zombie processes?
Summary: Wayland creating zombie processes?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: wayland
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 18:01 UTC by gareth foster
Modified: 2017-02-11 14:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-11 14:52:02 UTC
Type: Bug


Attachments (Terms of Use)

Description gareth foster 2017-02-02 18:01:55 UTC
Description of problem:
I was finding that my server was going weird after a few days running after upgrading to F25. It runs Kodi all the time, and Owncloud, and MythTV.
Anyway, I was finding that Kodi was still working, but SSH attempts would prompt for a password, then hang. I could get to some sort of BASH prompt with ctrl+c, but trying to run any programs, even top, would hang.
If I exited Kodi, everything would hang. If I tried to reboot the system, it would hang.
I wanted to try and search the system for zombie processes to see if there were no more free process IDs?
I don't think it was MythTV that caused it, as it still happened with that stopped.
I'm now running on Xorg, and it seems to be okay.
Might this be something about Kodi and Wayland?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 gareth foster 2017-02-11 14:52:02 UTC
This is now happening on Xorg as well, so it's not Wayland. No idea what the cause is.


Note You need to log in before you can comment on or make changes to this bug.