Bug 1418850 - [DOCS] Remove "Encrypting Hosts with IPsec" documentation page
Summary: [DOCS] Remove "Encrypting Hosts with IPsec" documentation page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: brice
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
: 1429034 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 21:37 UTC by Marc Curry
Modified: 2020-09-10 10:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-22 03:34:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 2 openshift-github-bot 2017-02-03 06:11:38 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/e79f37d9f6c6425b807aae8cc4a51c352249d915
Merge pull request #3652 from bfallonf/ipsec_1418850

Bug 1418850 Commented out ipsec file

Comment 3 brice 2017-02-03 06:15:36 UTC
Thanks, Marc.

PR created, and as it's an easy fix, merged:

https://github.com/openshift/openshift-docs/pull/3652

Moving this to release_pending.

Comment 8 Johnathan Kupferer 2017-02-22 22:43:54 UTC
Responding here for completeness.

I wrote up an updated version of the admin guid IPSec documentation documenting how to set up it up with libreswan 3.15 using explicit connection definitions rather than opportunistic groups:

https://github.com/jkupferer/openshift-docs/blob/master/admin_guide/ipsec.adoc

I also initiated a pull request for the updated documentation:

https://github.com/openshift/openshift-docs/pull/3642

Comment 9 Vikram Goyal 2017-02-23 05:06:54 UTC
(In reply to Johnathan Kupferer from comment #8)
> Responding here for completeness.
> 
> I wrote up an updated version of the admin guid IPSec documentation
> documenting how to set up it up with libreswan 3.15 using explicit
> connection definitions rather than opportunistic groups:
> 
> https://github.com/jkupferer/openshift-docs/blob/master/admin_guide/ipsec.
> adoc
> 
> I also initiated a pull request for the updated documentation:
> 
> https://github.com/openshift/openshift-docs/pull/3642

Hey Jonathan - the pull request is currently closed. Do you plan to submit another pull request?

Comment 10 brice 2017-02-23 05:18:35 UTC
Vikram,

He has, and I've merged it. It's here:

https://github.com/openshift/openshift-docs/pull/3823

Currently doing a followup. I'll include that in here as well.

Comment 11 brice 2017-02-23 05:40:21 UTC
Follow up PR: https://github.com/openshift/openshift-docs/pull/3825

Comment 12 Marcel Wysocki 2017-02-24 10:39:45 UTC
https://github.com/openshift/openshift-docs/pull/3652
can be reverted then ?

Comment 13 brice 2017-02-26 22:57:11 UTC
Marcel,

In my followup PR I place the ipsec files back into the _topic.yaml, so there's no need to revert #3652. I thought it was less difficult this way.

I'll merge #3825 today (which features Johnathan's PR as well), and it will be live in the docs soon.

Comment 14 brice 2017-02-27 02:02:38 UTC
Followup PR has merged:

https://github.com/openshift/openshift-docs/pull/3825

Will be live after the next weekly release. Moving this to release_pending.

Comment 15 Vikram Goyal 2017-03-06 01:33:42 UTC
*** Bug 1429034 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.