Bug 1418857 - oadm diagnostics pulls images from docker.io
Summary: oadm diagnostics pulls images from docker.io
Keywords:
Status: CLOSED DUPLICATE of bug 1439142
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Josep 'Pep' Turro Mauri
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 22:15 UTC by Ryan Howe
Modified: 2020-09-10 10:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-23 08:28:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ryan Howe 2017-02-02 22:15:34 UTC
Description of problem:

When running diagnostics we pull a busybox container from docker.io to test networking. Alot of enterprise users have removed docker.io access causing this to fail and show as an error. 

https://github.com/openshift/ose/blob/master/pkg/diagnostics/network/objects.go#L16-L21


We should pull an image to test from the RedHat registry.

Comment 3 Josep 'Pep' Turro Mauri 2017-05-22 17:11:08 UTC
*** Bug 1439142 has been marked as a duplicate of this bug. ***

Comment 5 Josep 'Pep' Turro Mauri 2017-05-23 08:28:53 UTC
Closing in favor of 1439142 which has some more discussion around this issue.

*** This bug has been marked as a duplicate of bug 1439142 ***


Note You need to log in before you can comment on or make changes to this bug.