Bug 1418890 - Don't run unify_hosts on upgrade
Summary: Don't run unify_hosts on upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1316897 1418892 1426418
TreeView+ depends on / blocked
 
Reported: 2017-02-03 01:04 UTC by Craig Donnelly
Modified: 2020-04-15 15:12 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1418892 (view as bug list)
Environment:
Last Closed: 2017-02-03 13:28:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
logs from cosnole while performing upgrade from sat61 - 6.2.7 on rhel7 (44.12 KB, text/plain)
2017-02-03 08:45 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0251 0 normal SHIPPED_LIVE Satellite Async Errata 2017-02-03 18:28:07 UTC

Description Craig Donnelly 2017-02-03 01:04:30 UTC
Description of problem:
When upgrading to Satellite 6.2.7, 'unify hosts' runs as part of the upgrade process.
Unfortunately, it does not seem to take into consideration whether or not the host being removed is 'Managed' by the Satellite via a Compute Resource.
This can cause the machine to be destroyed!

Version-Release number of selected component (if applicable): 6.2.7

How reproducible: ? (Have not yet attempted myself, will work on)


Steps to Reproduce:
1. Create system via compute resource, or register with shortname and set to managed.
2. Upgrade / manually invoke unify hosts script
3. Verify host destroyed afterward, check with Monitor -> Audit.

Actual results:
Unify hosts removed managed shortname host, destroyed system.

Expected results:
Unify hosts should handle or ignore managed hosts.

Comment 5 Mike McCune 2017-02-03 02:48:29 UTC
TESTPLAN

* Install Satellite 6.1

* Upgrade to Satellite 6.2

* Ensure you do *NOT* see this message in the satellite.log file in :

/var/log/foreman-installer/satellite.log


[ INFO 2017-01-26 10:41:08 main] Upgrade Step: unify_hosts (this may take a while) ...

if you don't see this message, the rake task was not run and this bug is VERIFIED

Comment 6 Sachin Ghai 2017-02-03 08:43:11 UTC
Performed upgrade from sat6.1.11 -> sat6.2.7 on rhel7 along w/ following two packages:

-bash-4.2# rpm -qa | grep katello-installer-base
katello-installer-base-3.0.0.71.1-1.el7sat.noarch
-bash-4.2# rpm -qa | grep foreman-installer-katello
foreman-installer-katello-3.0.0.71.1-1.el7sat.noarch

I don't see this "upgrade Step: unify_hosts (this may take a while)" while performing upgrade. Neither on console nor in /var/log/foreman-installer/satellite.log.

upgrade completed immediately after  "Upgrade Step: remove_event_queue..."

==
Upgrade Step: remove_event_queue...

Upgrade completed!
==

Comment 7 Sachin Ghai 2017-02-03 08:45:46 UTC
Created attachment 1247387 [details]
logs from cosnole while performing upgrade from sat61 - 6.2.7 on rhel7

Comment 9 Sachin Ghai 2017-02-03 10:14:00 UTC
Performed another upgrade from 6.2.6 -> 6.2.7 on rhel7 along w/

katello-installer-base-3.0.0.71.1-1.el7sat.noarch
foreman-installer-katello-3.0.0.71.1-1.el7sat.noarch

and I don't see the "upgrade Step: unify_hosts (this may take a while)"

Upgrade was completed after db:seed step.

---
out: Upgrade Step: db_seed...
[SAT_SERVER] out: Seeding /usr/share/foreman/db/seeds.d/03-auth_sources.rb
----
<truncate>
[SAT_SERVER] out: Upgrade completed!
----

Comment 10 Sanket Jagtap 2017-02-03 11:10:47 UTC
Performed upgrade from sat6.1.11 -> sat6.2.7 on rhel6 
Performed upgrade from 6.2.6 -> 6.2.7 on rhel6
along w/ following two packages:

katello-installer-base-3.0.0.71.1-1.el6sat.noarch
foreman-installer-katello-3.0.0.71.1-1.el6sat.noarch

there was no "upgrade Step: unify_hosts" step while upgrading 


satellite.log output for both attached

Comment 13 Sachin Ghai 2017-02-03 11:19:02 UTC
Moving to verified state as per comments above.

Comment 15 errata-xmlrpc 2017-02-03 13:28:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0251


Note You need to log in before you can comment on or make changes to this bug.