Bug 1418909 - RHGS ISO: gluster-deploy script provided at /usr/lib/glusterfs/.unsupported is not appropriate with the current release version
Summary: RHGS ISO: gluster-deploy script provided at /usr/lib/glusterfs/.unsupported i...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Milind Changire
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 05:35 UTC by Prasad Desala
Modified: 2019-07-10 13:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 13:55:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Prasad Desala 2017-02-03 05:35:44 UTC
Description of problem:
=======================
In latest 3.2.0 RHGS ISO, the gluster-deploy script provided at /usr/lib/glusterfs/.unsupported is not appropriate with the current release version. The current gdeploy version running with the iso is gdeploy-2.0.1-8.el6rhs.noarch but the gdeploy script provided at /usr/lib/glusterfs/.unsupported is having a very older version i.e gluster-deploy-0.8. 

drwxr-xr-x. 7 root root  4096 Feb  2 01:42 gluster-deploy-0.8

Seems like this gluster-deploy directory is not being used for any purpose as the directory was not updated since a long time. In that case the directory "gluster-deploy-0.8" can be removed from the iso to reduce the size of iso.
 
If purposefully the gdeploy script is placed then it has to be updated with the latest version.  

Version-Release number of selected component (if applicable):
3.8.4-13.el6rhs.x86_64

RHGS ISO location:
==================
RHGS-3.2-RHEL-6.8-z : http://download-node-02.eng.bos.redhat.com/nightly/RHGS/3.2/RHGSS-3.2-RHEL-6-20170130.n.1/compose/RHGSS/x86_64/iso/RHGSS-3.2-RHEL-6-20170130.n.1-RHGSS-x86_64-dvd1.iso

RHGS-3.2-RHEL-7.3-z  : http://download-node-02.eng.bos.redhat.com/nightly/RHGS/3.2/RHGSS-3.2-RHEL-7-20170131.n.0/compose/RHGSS/x86_64/iso/RHGSS-3.2-RHEL-7-20170131.n.0-RHGSS-x86_64-dvd1.iso

Comment 5 Amar Tumballi 2018-11-20 04:16:24 UTC
Hi Milind, I see you moving the assignee to rhs-bugs, but without telling what is required to be done to resolve this bug.

Can you update what we have to do to resolve the bug? If there is nothing from Engineering, then it would be good to CLOSE the bug (with relevant reason, can even be WONTFIX).

Comment 6 Milind Changire 2018-11-20 04:55:03 UTC
I'm not sure if gluster-deploy is the same as gdeploy.
If they are the same, then we need to remove gluster-deploy from redhat-storage-server RPM.

@Sac: are they the same ?

Comment 7 Sachidananda Urs 2018-11-20 05:49:03 UTC
(In reply to Milind Changire from comment #6)
> I'm not sure if gluster-deploy is the same as gdeploy.
> If they are the same, then we need to remove gluster-deploy from
> redhat-storage-server RPM.
> 
> @Sac: are they the same ?

They are not same, this was a script shipped a long time back.
I'm not sure if anyone used it at all. We can remove it and take
the bug to closure.


Note You need to log in before you can comment on or make changes to this bug.