Bug 1418943 - If a long-running task (e.g. enumeration) blocks the sssd_be process, sssd_be can deadlock
Summary: If a long-running task (e.g. enumeration) blocks the sssd_be process, sssd_be...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Amith
URL:
Whiteboard:
Depends On: 1396912
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 08:47 UTC by Jaroslav Reznik
Modified: 2020-06-11 13:16 UTC (History)
18 users (show)

Fixed In Version: sssd-1.14.0-43.el7_3.13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1396912
Environment:
Last Closed: 2017-04-12 12:34:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 4299 0 None None None 2020-05-04 11:00:27 UTC
Red Hat Product Errata RHBA-2017:0908 0 normal SHIPPED_LIVE sssd bug fix update 2017-04-12 16:25:28 UTC

Description Jaroslav Reznik 2017-02-03 08:47:48 UTC
This bug has been copied from bug #1396912 and has been proposed
to be backported to 7.3 z-stream (EUS).

Comment 4 Amith 2017-03-30 03:39:55 UTC
Verified the bug on SSSD version: sssd-1.14.0-43.el7_3.14

Steps followed during verification:

1. Setup ldap with with 25000 users.

2. Setup client with enumeration = true in sssd.conf

3. Run user auth and lookup to verify whether sssd_be process is hanged or not.

Automated these steps in the SSSD Performance test suite and also executed the regression round.
See beaker link: https://beaker.engineering.redhat.com/jobs/1786406

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: sssdbe can deadlock if a long running task like enumeration blocks it bz1418943
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: Sleeping for 5 seconds
:: [   PASS   ] :: Command 'getent -s sss passwd puser15999' (Expected 0, got 0)
:: [   LOG    ] :: Authentication successfull, as expected
:: [   LOG    ] :: Duration: 3m 18s
:: [   LOG    ] :: Assertions: 1 good, 0 bad
:: [   PASS   ] :: RESULT: sssdbe can deadlock if a long running task like enumeration blocks it bz1418943

Comment 6 errata-xmlrpc 2017-04-12 12:34:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0908


Note You need to log in before you can comment on or make changes to this bug.