Bug 1418985 - Missing dependency for collectd deploy - rrdtool
Summary: Missing dependency for collectd deploy - rrdtool
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.1.0.3
Hardware: All
OS: All
unspecified
high vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1405813
TreeView+ depends on / blocked
 
Reported: 2017-02-03 11:09 UTC by Lukas Svaty
Modified: 2017-03-27 14:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 14:53:53 UTC
oVirt Team: Metrics
lsvaty: planning_ack?
lsvaty: devel_ack?
lsvaty: testing_ack?


Attachments (Terms of Use)

Description Lukas Svaty 2017-02-03 11:09:02 UTC
Description of problem:
When setting up collectd on hosts via engine script /usr/share/ovirt-engine/setup/ansible/configure_ovirt_hosts_for_metrics.sh
collectd fails to start due to missing dependency rrdtool. 

Version-Release number of selected component (if applicable):
collectd-rrdtool-5.7.0-2.el7.x86_64
collectd-5.7.0-2.el7.x86_64
rhevm-4.1.0.3-0.1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. run /usr/share/ovirt-engine/setup/ansible/configure_ovirt_hosts_for_metrics.sh on engine
 

Actual results:
TASK [collectd : Enable collectd] **********************************************
fatal: [**.**.**.**]: FAILED! => {"changed": false, "failed": true, "msg": "Unable to start service collectd: Job for collectd.service failed because the control process exited with error code. See \"systemctl status collectd.service\" and \"journalctl -xe\" for details.\n"}

looking into journal on host will show you its cause of missing dependency


Additional info:
WA: yum install collectd-rrdtool on hosts

Comment 1 Yedidyah Bar David 2017-02-06 14:53:53 UTC
The collectd build supplied by CentOS OpsTools SIG, which is used by oVirt, is not affected. Closing.

Comment 2 Lukas Svaty 2017-03-27 14:47:33 UTC
With the last build this is indeed working as collectd-rrdtool was removed from deps.


Note You need to log in before you can comment on or make changes to this bug.