Bug 1418999 - [GDEPLOY+GANESHA] Gdeploy fails to delete a node from ganesha cluster
Summary: [GDEPLOY+GANESHA] Gdeploy fails to delete a node from ganesha cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: RHGS 3.3.0
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1417147
TreeView+ depends on / blocked
 
Reported: 2017-02-03 12:01 UTC by Manisha Saini
Modified: 2017-09-21 04:49 UTC (History)
9 users (show)

Fixed In Version: gdeploy-2.0.1-2
Doc Type: Bug Fix
Doc Text:
Deletion of a node from NFS Ganesha would fail, as the playbook `hosts' section was not pointed to the correct node. Workaround: The node has to be deleted using the script: /usr/libexec/ganesha/ganesha-ha.sh
Clone Of:
Environment:
Last Closed: 2017-09-21 04:49:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2777 0 normal SHIPPED_LIVE gdeploy bug fix and enhancement update for RHEL7 2017-09-21 08:23:08 UTC

Description Manisha Saini 2017-02-03 12:01:13 UTC
Description of problem:
Gdeploy fails to delete a node from existing ganesha cluster

Version-Release number of selected component (if applicable):
# rpm -qa | grep gdeploy
gdeploy-2.0.1-9.el7rhgs.noarch

How reproducible:
Consistently

Steps to Reproduce:
1.Create 5 Node ganesha cluster.Enable ganesha on it
2.From gdeploy delete 1 node from 5 node ganesha cluster

# cat delete_node.conf 
[hosts]
dhcp46-87.lab.eng.blr.redhat.com
dhcp46-96.lab.eng.blr.redhat.com
dhcp46-112.lab.eng.blr.redhat.com
dhcp47-41.lab.eng.blr.redhat.com
dhcp46-38.lab.eng.blr.redhat.com

[nfs-ganesha]
action=delete-node
nodes=dhcp46-38.lab.eng.blr.redhat.com



=============
# gdeploy -c delete_node.conf 

PLAY RECAP *********************************************************************
============

Actual results:
It fails to delete the node from ganesha cluster

Expected results:
Gdeploy should be able to delete the node from ganesha cluster

Additional info:

Comment 3 Manisha Saini 2017-02-06 11:41:43 UTC
Atin,

To delete a node from the cluster, we have to execute the following command on any of the nodes in the existing NFS-Ganesha cluster:

 /usr/libexec/ganesha/ganesha-ha.sh --delete <HA_CONF_DIR> <HOSTNAME>


where <HA_CONF_DIR> is /var/run/gluster/shared_storage/nfs_ganesha
<HOSTNAME> hostname of the node which we want to delete

eg-
/usr/libexec/ganesha/ganesha-ha.sh --delete /var/run/gluster/shared_storage/nfs-ganesha/ dhcp46-232.lab.eng.blr.redhat.com

Comment 6 Atin Mukherjee 2017-02-07 14:19:53 UTC
@Rejy - can you please take out the blocker flag?

Comment 8 Bhavana 2017-03-14 05:29:15 UTC
The doc text is edited for the release notes.

Comment 10 Manisha Saini 2017-04-12 17:26:29 UTC
Verified this bug on 

[root@dhcp47-132 home]# rpm -qa | grep gdeploy
gdeploy-2.0.2-2.el7rhgs.noarch

Delete node config file -

# cat delete_node.conf 
[hosts]
dhcp47-147.lab.eng.blr.redhat.com
dhcp47-141.lab.eng.blr.redhat.com
dhcp47-144.lab.eng.blr.redhat.com
dhcp47-139.lab.eng.blr.redhat.com
dhcp47-132.lab.eng.blr.redhat.com


[nfs-ganesha]
action=delete-node
nodes=dhcp47-132.lab.eng.blr.redhat.com


As the issue is no more observed,hence moving this bug to Verified state

Comment 12 errata-xmlrpc 2017-09-21 04:49:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2777


Note You need to log in before you can comment on or make changes to this bug.