Bug 1419033 - Cannot save an edited class schema, get the error "Error during 'save': Name can't be blank"
Summary: Cannot save an edited class schema, get the error "Error during 'save': Name ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.6.4
Assignee: Harpreet Kataria
QA Contact: Milan Falešník
URL:
Whiteboard: automate
: 1419550 (view as bug list)
Depends On: 1404788
Blocks: 1382817
TreeView+ depends on / blocked
 
Reported: 2017-02-03 13:32 UTC by Satoe Imaishi
Modified: 2017-03-09 17:09 UTC (History)
11 users (show)

Fixed In Version: 5.6.4.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1404788
Environment:
Last Closed: 2017-03-09 17:09:06 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0474 0 normal SHIPPED_LIVE CFME 5.6.4 bug fixes and enhancement update 2017-03-09 22:03:14 UTC

Comment 2 CFME Bot 2017-02-03 17:41:02 UTC
New commit detected on ManageIQ/manageiq/darga:
https://github.com/ManageIQ/manageiq/commit/da26aee041a353917cf9779127f1a139b89b0e1c

commit da26aee041a353917cf9779127f1a139b89b0e1c
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Thu Dec 15 14:23:58 2016 -0500
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Fri Feb 3 12:36:39 2017 -0500

    Merge pull request #13201 from h-kataria/ae_schema_editor_fix
    
    Fixed code to expect/set keys as strings instead of symbols in edit hash
    (cherry picked from commit 789d77ab3c76f8c36ef22c2584d34ae42d625c4c)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1419033

 app/controllers/miq_ae_class_controller.rb       | 22 +++++++-------
 app/views/miq_ae_class/_class_fields.html.haml   | 20 ++++++-------
 spec/controllers/miq_ae_class_controller_spec.rb | 38 +++++++++++++++++++++++-
 3 files changed, 57 insertions(+), 23 deletions(-)

Comment 3 Harpreet Kataria 2017-02-07 16:02:26 UTC
*** Bug 1419550 has been marked as a duplicate of this bug. ***

Comment 4 Milan Falešník 2017-03-03 12:58:52 UTC
Verified in 5.6.4.2. I was able to add an another field in the copied class' schema.

Comment 6 errata-xmlrpc 2017-03-09 17:09:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0474.html


Note You need to log in before you can comment on or make changes to this bug.