Bug 1419052 - [RFE] Include collectd-turbostat installed on overcloud image
Summary: [RFE] Include collectd-turbostat installed on overcloud image
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-images
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 14:34 UTC by Alex Krzos
Modified: 2019-01-08 16:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-08 16:17:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alex Krzos 2017-02-03 14:34:02 UTC
Description of problem:
Now that Ops-tools rpms such as collectd are included on the overcloud image, we should include collectd-turbostat to allow the use of the turbostat plugin.

What is currently included:

[root@overcloud-controller-0 ~]# rpm -qa | grep collectd
collectd-curl-5.5.2-2.el7ost.x86_64
collectd-utils-5.5.2-2.el7ost.x86_64
collectd-smart-5.5.2-2.el7ost.x86_64
collectd-mysql-5.5.2-2.el7ost.x86_64
collectd-disk-5.5.2-2.el7ost.x86_64
collectd-rrdtool-5.5.2-2.el7ost.x86_64
collectd-5.5.2-2.el7ost.x86_64
collectd-iptables-5.5.2-2.el7ost.x86_64
collectd-curl_xml-5.5.2-2.el7ost.x86_64
collectd-lvm-5.5.2-2.el7ost.x86_64
collectd-ping-5.5.2-2.el7ost.x86_64
libcollectdclient-5.5.2-2.el7ost.x86_64
collectd-ipmi-5.5.2-2.el7ost.x86_64
collectd-netlink-5.5.2-2.el7ost.x86_64
collectd-write_http-5.5.2-2.el7ost.x86_64
collectd-sensors-5.5.2-2.el7ost.x86_64
puppet-collectd-5.3.0-0.20170124210727.391f683.el7ost.noarch
collectd-virt-5.5.2-2.el7ost.x86_64
collectd-ceph-5.5.2-2.el7ost.x86_64
collectd-write_sensu-5.5.2-2.el7ost.x86_64
collectd-rrdcached-5.5.2-2.el7ost.x86_64
collectd-curl_json-5.5.2-2.el7ost.x86_64
collectd-apache-5.5.2-2.el7ost.x86_64


Version-Release number of selected component (if applicable):
Ocata/OSP11 Build 2017-02-01.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

We use the turbostat plugin within OpenStack/Browbeat to verify cpu % c state and freq during testing. [0]

[0] https://github.com/openstack/browbeat

Comment 2 Matthias Runge 2018-01-25 12:16:49 UTC
The turbostat plugin is already included in kolla.
https://github.com/openstack/kolla/blob/master/docker/collectd/Dockerfile.j2#L28

Comment 3 Matthias Runge 2018-01-25 12:27:03 UTC
The change was merged into kolla on Sept 12 2017

Comment 4 Matthias Runge 2018-01-25 12:59:29 UTC
Alex, would you be able to check if the plugin is included in the overcloud image? Technically, it should be included since OSP12.

Comment 5 Alex Krzos 2018-02-06 17:19:01 UTC
(In reply to Matthias Runge from comment #4)
> Alex, would you be able to check if the plugin is included in the overcloud
> image? Technically, it should be included since OSP12.

I don't see it yet.

[root@overcloud-controller-0 ~]# rpm -qa | grep collectd
libcollectdclient-5.7.2-1.1.el7ost.x86_64
collectd-netlink-5.7.2-1.1.el7ost.x86_64
collectd-apache-5.7.2-1.1.el7ost.x86_64
collectd-smart-5.7.2-1.1.el7ost.x86_64
collectd-iptables-5.7.2-1.1.el7ost.x86_64
collectd-sensors-5.7.2-1.1.el7ost.x86_64
collectd-ping-5.7.2-1.1.el7ost.x86_64
collectd-curl_xml-5.7.2-1.1.el7ost.x86_64
collectd-write_http-5.7.2-1.1.el7ost.x86_64
collectd-write_sensu-5.7.2-1.1.el7ost.x86_64
collectd-rrdtool-5.7.2-1.1.el7ost.x86_64
collectd-5.7.2-1.1.el7ost.x86_64
collectd-mysql-5.7.2-1.1.el7ost.x86_64
collectd-utils-5.7.2-1.1.el7ost.x86_64
collectd-curl_json-5.7.2-1.1.el7ost.x86_64
puppet-collectd-5.3.1-0.1.b995bdagit.el7ost.noarch
collectd-rrdcached-5.7.2-1.1.el7ost.x86_64
collectd-virt-5.7.2-1.1.el7ost.x86_64
collectd-ipmi-5.7.2-1.1.el7ost.x86_64
collectd-disk-5.7.2-1.1.el7ost.x86_64
collectd-lvm-5.7.2-1.1.el7ost.x86_64
collectd-curl-5.7.2-1.1.el7ost.x86_64
collectd-ceph-5.7.2-1.1.el7ost.x86_64

Comment 6 Jon Schlueter 2019-01-08 16:15:30 UTC
rhosp-director-images is not related to kolla or overcloud images.


Note You need to log in before you can comment on or make changes to this bug.