Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419062 - [ESX][open-vm-tools][RHEL7.4]When running docker containers, the open-vm-tools SyncDriver fails to quiesce filesystems and returns an error
Summary: [ESX][open-vm-tools][RHEL7.4]When running docker containers, the open-vm-tool...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: open-vm-tools
Version: 7.3
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: ldu
URL:
Whiteboard:
Depends On: 1406483
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 15:08 UTC by Jaroslav Reznik
Modified: 2020-09-10 10:10 UTC (History)
18 users (show)

Fixed In Version: open-vm-tools-10.0.5-4.el7_3
Doc Type: Bug Fix
Doc Text:
Prior to this update, taking a snapshot of a Red Hat Enterprise Linux 7 guest on the VMWare ESXi hypervisor failed if docker images were running on the guest. With this update, the vmtoolsd service properly quiesces the guest file system in the described scenario, which makes it possible for the snapshots to be taken.
Clone Of: 1406483
Environment:
Last Closed: 2017-03-02 17:27:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0391 0 normal SHIPPED_LIVE open-vm-tools bug fix and enhancement update 2017-03-02 22:06:53 UTC

Description Jaroslav Reznik 2017-02-03 15:08:05 UTC
This bug has been copied from bug #1406483 and has been proposed
to be backported to 7.3 z-stream (EUS).

Comment 4 Richard W.M. Jones 2017-02-03 16:37:57 UTC
For those wishing to test the open-vm-tools package containing
fixes for bug 1418949, bug 1419059 and bug 1419062:

http://oirase.annexia.org/tmp/bz1418949/

Comment 7 GOS QA 2017-02-07 09:53:47 UTC
(In reply to Richard W.M. Jones from comment #4)
> For those wishing to test the open-vm-tools package containing
> fixes for bug 1418949, bug 1419059 and bug 1419062:
> 
> http://oirase.annexia.org/tmp/bz1418949/

Hi Richard,

We have reproduced the issues: 1418949, 1419059 and 1419062, and verified the fixes in the patch bz1418949.  

Tomorrow we're going to review it with other team to see if any impacted areas should be tested, and what kind of regression testing is needed.

Could you send us the diff file of the source code change in this patch? So that we could evaluate which might be impacted and should be tested.

Thank you very much!

Best regards,
Hang Rao

Comment 8 Richard W.M. Jones 2017-02-07 11:07:34 UTC
You've already got it.  Unpack the SRPM and examine the source
and patches:

$ echo "%_topdir $HOME/rpmbuild" > ~/.rpmmacros
$ rpm -ivh open-vm-tools-10.0.5-4.el7_3.src.rpm
$ cd rpmbuild/

and examine SPECS/open-vm-tools.spec and SOURCES/*

Comment 9 GOS QA 2017-02-07 23:12:39 UTC
(In reply to Richard W.M. Jones from comment #8)
> You've already got it.  Unpack the SRPM and examine the source
> and patches:
> 
> $ echo "%_topdir $HOME/rpmbuild" > ~/.rpmmacros
> $ rpm -ivh open-vm-tools-10.0.5-4.el7_3.src.rpm
> $ cd rpmbuild/
> 
> and examine SPECS/open-vm-tools.spec and SOURCES/*

Thanks, will look at it.

Comment 10 ldu 2017-02-09 06:35:32 UTC
verify this bug with RHEL7.3 guest on ESXi 6.0 host.

As this bug mentioned in comments 7, QE from vmware had verified this bug,
so we did some sanity test with open-vm-tools-10.0.5-4.el7_3.x86_64.rpm and open-vm-tools-desktop-10.0.5-4.el7_3.x86_64.rpm,no issue found.
It is pass with sanity test.
The bug related host version: ESXi 6.0
The bug related guest version: kernel 3.10.0-514.6.1.el7.x86_64
The test result: Verified

Comment 11 GOS QA 2017-02-09 10:10:23 UTC
We (VMware GOSV QE) also have done the verification for this bug.
Test Env:
  Host: Esxi6.5GA
  Guest:RHEL7.3 + the provided open-vm-tools-10.0.5-4.el7_3.x86_64.rpm and open-vm-tools-desktop-10.0.5-4.el7_3.x86_64.rpm

Test scenario:
  1. Checked QuiesceSnapshot With Docker container running;
  2. Several other positive and negative testings for QuiesceSnapshot;
  3. Checked whether all the necessary files and services are present. 

All the testings are Pass.

Comment 13 errata-xmlrpc 2017-03-02 17:27:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0391.html


Note You need to log in before you can comment on or make changes to this bug.