Bug 1419116 - podfying cfme: failing deployment on 3.4 with error on liveness probe
Summary: podfying cfme: failing deployment on 3.4 with error on liveness probe
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation
Version: 5.7.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: GA
: cfme-future
Assignee: Red Hat CloudForms Documentation
QA Contact: Red Hat CloudForms Documentation
URL:
Whiteboard: container
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 15:37 UTC by Dafna Ron
Modified: 2018-07-02 09:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-02 09:16:27 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description Dafna Ron 2017-02-03 15:37:12 UTC
Description of problem:


deployment keeps failing with the below error (which also seems to be cut so I don't know what with what to complete the command (-- echo ok, --open-tcp=3306? there are lots of options )

 * pod/cloudforms-1-deploy has no liveness probe to verify pods are still running.
    try: oc set probe pod/cloudforms-1-deploy --liveness ...


Version-Release number of selected component (if applicable):

CFME 5.8.0.0 
oc v3.4.0.40

How reproducible:

100% 

Steps to Reproduce:
1. deploy cfme pod 
2. oc status -v 
3.

Actual results:

we are failing on error 

* pod/cloudforms-1-deploy has no liveness probe to verify pods are still running.
    try: oc set probe pod/cloudforms-1-deploy --liveness ...

Expected results:

we should have available probes
command output should not be cut

Additional info:

http://pastebin.test.redhat.com/452166

I tried a oc deploy <pod> --retry but still failing on the same error. 


Warnings:
  * pod/cloudforms-1-deploy has no liveness probe to verify pods are still running.
    try: oc set probe pod/cloudforms-1-deploy --liveness ...
  * pod/postgresql-1-deploy has no liveness probe to verify pods are still running.
    try: oc set probe pod/postgresql-1-deploy --liveness ...

View details with 'oc describe <resource>/<name>' or list everything with 'oc get all'.
You have new mail in /var/spool/mail/root
[root@dafna-openshift-master01 manageiq-pods]# oc get pods
NAME                  READY     STATUS    RESTARTS   AGE
cloudforms-1-deploy   0/1       Error     0          38m
memcached-1-tawbp     1/1       Running   0          37m
postgresql-1-deploy   0/1       Error     0          38m

Comment 3 Franco Bladilo 2017-02-07 14:31:59 UTC
Dafna,

We have no control over the deployer Pods, they are launched by OpenShift to assist the deployment of your requested Pods which all have liveness and readiness probes. 

It appears the deployment failed and went on error for other reasons : 

https://cloudforms-dafna-test.dafna-openshift-master01.qa.lab.tlv.redhat.com (passthrough) to pod port https (svc/cloudforms)
  dc/cloudforms deploys istag/cfme-openshift-app:latest
    deployment #1 failed about an hour ago: image change
 
svc/memcached - 172.30.197.91:11211
  dc/memcached deploys istag/cfme-openshift-memcached:latest
    deployment #1 deployed about an hour ago - 1 pod
 
svc/postgresql - 172.30.142.25:5432
  dc/postgresql deploys istag/cfme-openshift-postgresql:latest
    deployment #1 failed about an hour ago: image change

It seems like something went wrong with the images but without the actual POD logs, I'm not able to tell. Can you reproduce this if you clean your environment and start over on 58 images?

Comment 5 Dafna Ron 2017-02-10 12:48:16 UTC
after increasing vm memory to 12GB and vcpu to 8 I was able to deploy. 
not closing because I think this might need to become a doc bug

Comment 6 Barak 2017-03-16 19:11:56 UTC
Per comment #5 this is not relevant any more,
Moving to documentation to make sure this is captured and updated in the official docs.

Comment 7 Andrew Dahms 2017-05-09 04:02:44 UTC
Hi Barak,

Thank you for moving this bug over.

Just to confirm - are the memory and vCPU settings something the user needs to specify, or are they preset in the image itself?

At current, we don't call out these requirements in the documentation by the looks of it, and I am thinking of the best way to present these details.

Kind regards,

Andrew

Comment 8 Barak 2017-05-09 10:12:53 UTC
(In reply to Andrew Dahms from comment #7)
> Hi Barak,
> 
> Thank you for moving this bug over.
> 
> Just to confirm - are the memory and vCPU settings something the user needs
> to specify, or are they preset in the image itself?


These values has defaults that appear in the openshift template for cfme,
and they could be overridden on the deployment by providing the appropriate values. 


> 
> At current, we don't call out these requirements in the documentation by the
> looks of it, and I am thinking of the best way to present these details.


I thinks the defaults should be the same as the VM appliance to begin with (memory & cpu) and the defaults should (and I think they already do) reflect these values. they should be written/appear in the documentation the same way they appear for the vm appliance (keep in mind that the PODified is always considered as external DB appliance) 



> 
> Kind regards,
> 
> Andrew

Comment 9 Loic Avenel 2018-07-02 09:16:27 UTC
OpenShift 3.7 only is supported with Podify and CF 4.6


Note You need to log in before you can comment on or make changes to this bug.