Bug 1419122 - Review Request: rubygem-base32 - Ruby extension for base32 encoding and decoding
Summary: Review Request: rubygem-base32 - Ruby extension for base32 encoding and decoding
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Sascha Spreitzer (Red Hat)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 15:58 UTC by Marcel Haerry
Modified: 2017-03-27 20:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 20:50:22 UTC
Type: ---
sspreitz: fedora-review+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1424958 None None None 2017-02-20 08:00:44 UTC

Internal Links: 1424957 1424958

Description Marcel Haerry 2017-02-03 15:58:12 UTC
Spec URL: http://git.scrit.ch/srpm/rubygem-base32/tree/SPECS/rubygem-base32.spec
SRPM URL: https://kojipkgs.fedoraproject.org//work/tasks/380/17570380/rubygem-base32-0.3.2-1.fc26.src.rpm
Description: Ruby extension for base32 encoding and decoding.
Fedora Account System Username: maha

Comment 1 Sascha Spreitzer (Red Hat) 2017-02-03 17:26:17 UTC
Hi Marcel

I will be reviewing your request.
Can you please also provide a koji scratch build link?

Thank you
Sascha

Comment 2 Marcel Haerry 2017-02-04 08:14:49 UTC
Sure, it's the one from where the SRPM link comes. But yeah a direct link is way more convenient: https://koji.fedoraproject.org/koji/taskinfo?taskID=17570380

Comment 3 Sascha Spreitzer (Red Hat) 2017-02-05 11:48:37 UTC
Thank you!

As I am using fedora-review it is better I am pasting the plain/raw link version of the spec link here for automatic processing.

Spec URL: http://git.scrit.ch/srpm/rubygem-base32/plain/SPECS/rubygem-base32.spec
SRPM URL: https://kojipkgs.fedoraproject.org//work/tasks/380/17570380/rubygem-base32-0.3.2-1.fc26.src.rpm

Comment 6 Sascha Spreitzer (Red Hat) 2017-02-05 13:49:10 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package contains Requires: ruby(release).


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "MIT/X11 (BSD like)", "Unknown or generated". 9 files have
     unknown license. Detailed output of licensecheck in
     /home/fedora/1419122-rubygem-base32/licensecheck.txt
[!]: License file installed when any subpackage combination is installed.
[x]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/gems,
     /usr/share/gems/doc
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[-]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

Ruby:
[-]: Platform dependent files must all go under %{gem_extdir_mri}, platform
     independent under %{gem_dir}.
[x]: Gem package must not define a non-gem subpackage
[x]: Macro %{gem_extdir} is deprecated.
[x]: Gem package is named rubygem-%{gem_name}
[x]: Package contains BuildRequires: rubygems-devel.
[x]: Gem package must define %{gem_name} macro.
[x]: Pure Ruby package must be built as noarch
[x]: Package does not contain Requires: ruby(abi).

===== SHOULD items =====

Generic:
[-]: Avoid bundling fonts in non-fonts packages.
     Note: Package contains font files
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in rubygem-
     base32-doc
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[-]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

Ruby:
[!]: Gem should use %gem_install macro.
[x]: Gem package should exclude cached Gem.
[x]: gems should not require rubygems package
[x]: Specfile should use macros from rubygem-devel package.
[x]: Test suite should not be run by rake.
[x]: Test suite of the library should be run.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Cannot parse rpmlint output:


Rpmlint (installed packages)
----------------------------
Cannot parse rpmlint output:


Requires
--------
rubygem-base32-doc (rpmlib, GLIBC filtered):
    rubygem-base32

rubygem-base32 (rpmlib, GLIBC filtered):
    ruby(rubygems)



Provides
--------
rubygem-base32-doc:
    rubygem-base32-doc

rubygem-base32:
    rubygem(base32)
    rubygem-base32



Source checksums
----------------
https://rubygems.org/gems/base32-0.3.2.gem :
  CHECKSUM(SHA256) this package     : 532e9b19c5dd1fce281df67fc93a803ebd5d26426a93f6dda6612769bc46fe2c
  CHECKSUM(SHA256) upstream package : 532e9b19c5dd1fce281df67fc93a803ebd5d26426a93f6dda6612769bc46fe2c


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -b 1419122
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Ruby, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 7 Sascha Spreitzer (Red Hat) 2017-02-05 13:50:04 UTC
Hi Marcel

- Please add the license file to all packages and subpackages via %license, i think it is either missing in the main package or the -doc subpackage
- Please make use of the %gem_install macro

Comment 8 Sascha Spreitzer (Red Hat) 2017-02-05 13:55:53 UTC
So, overall it looks very good.

Only things to clarify:

Must:
! license file in all packages
? %gem_install and %install sections -> double work?

Optional:
? Tabstops for the tags to have a nicer specfile, eg.:

Name:\t\t%{gem_name}
Version:\t\t%{gem_version}
etc...

Comment 9 Marcel Haerry 2017-02-06 14:14:35 UTC
Thanks for reviewing

So:

license:

I added the licensefile to -doc: http://git.scrit.ch/srpm/rubygem-base32/commit/?id=04662f077c193b38e3564fae97541e4f06cde01a

gem_install:

I don't really understand the problem with %gem_install, as I am using it:

http://git.scrit.ch/srpm/rubygem-base32/tree/SPECS/rubygem-base32.spec#n46

AND I think I closely follow the guidelines in the wiki

https://fedoraproject.org/wiki/Packaging:Ruby#.25build

Is the review test broken here? Can you otherwise be more specific?

Thanks!

Comment 10 Marcel Haerry 2017-02-06 14:17:52 UTC
new scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=17633948

Comment 11 Simone Caronni 2017-02-07 08:23:23 UTC
Hi Sasha,

just a couple of notes.

(In reply to Sascha Spreitzer from comment #3)
> As I am using fedora-review it is better I am pasting the plain/raw link
> version of the spec link here for automatic processing.
> 
> Spec URL:
> http://git.scrit.ch/srpm/rubygem-base32/plain/SPECS/rubygem-base32.spec
> SRPM URL:
> https://kojipkgs.fedoraproject.org//work/tasks/380/17570380/rubygem-base32-0.
> 3.2-1.fc26.src.rpm

fedora-review is "smart enough" to actually get the links in the last comment in which they are available, you don't need to make sure they are in the last comment before the actual fedora-review process.

(In reply to Sascha Spreitzer from comment #8)
> Must:
> ! license file in all packages

Actually you need to make sure that the license is available in any package installation combination. So judging by a quick look from the spec file, the -doc subpackage requires the main package to be installed, so the license is enough to be available in the main package as it is always installed when -doc is.

PS: I'm not watching you, but when you sponsor someone you are notified of the Bugzilla actions of the person you've sponsored :P

Comment 12 Sascha Spreitzer (Red Hat) 2017-02-07 08:43:28 UTC
Hi Simone

> fedora-review is "smart enough" to actually get the links in the last comment 
> in which they are available, you don't need to make sure they are in the last 
> comment before the actual fedora-review process.

I had to add the link as fedora-review could not extract the raw/plain version from the provided link.

> Actually you need to make sure that the license is available in any package 
> installation combination. So judging by a quick look from the spec file, the 
> -doc subpackage requires the main package to be installed, so the license is 
> enough to be available in the main package as it is always installed when -doc 
> is.

Sounds good to me then.

> PS: I'm not watching you, but when you sponsor someone you are notified of the 
> Bugzilla actions of the person you've sponsored :P

All input that makes Fedora a good Linux distribution is very welcome!

Comment 13 Sascha Spreitzer (Red Hat) 2017-02-07 08:52:06 UTC
Hi Marcel

(In reply to Marcel Haerry from comment #9)
> gem_install:
> 
> I don't really understand the problem with %gem_install, as I am using it:
> 
> http://git.scrit.ch/srpm/rubygem-base32/tree/SPECS/rubygem-base32.spec#n46
> 
> AND I think I closely follow the guidelines in the wiki
> 
> https://fedoraproject.org/wiki/Packaging:Ruby#.25build
> 
> Is the review test broken here? Can you otherwise be more specific?

The fedora-review tool is highlighting the %gem_install being missed, but i can see it in the spec file. And additionally there is an %install section.
Please give me some time to find out why fedora-review is failing and if %install in addition to %gem_install is permissible.

Comment 14 Marcel Haerry 2017-02-07 09:22:17 UTC
(In reply to Simone Caronni from comment #11)
> (In reply to Sascha Spreitzer from comment #8)
> > Must:
> > ! license file in all packages
> 
> Actually you need to make sure that the license is available in any package
> installation combination. So judging by a quick look from the spec file, the
> -doc subpackage requires the main package to be installed, so the license is
> enough to be available in the main package as it is always installed when
> -doc is.


Oh that's good to know. I already wondered why gem2rpm would create an invalid specfile. But given that background, I understand it that fedora-review is wrong here and I can revert the commit. Fine?

Comment 15 Sascha Spreitzer (Red Hat) 2017-02-07 09:34:42 UTC
(In reply to Marcel Haerry from comment #14)
> Oh that's good to know. I already wondered why gem2rpm would create an
> invalid specfile. But given that background, I understand it that
> fedora-review is wrong here and I can revert the commit. Fine?

Yes, that is fine.

Comment 16 Marcel Haerry 2017-02-07 11:18:14 UTC
Done, so the %gem_install part is the only open part.

Comment 17 Vít Ondruch 2017-02-13 09:42:58 UTC
(In reply to Sascha Spreitzer from comment #13)
> Hi Marcel
> 
> (In reply to Marcel Haerry from comment #9)
> > gem_install:
> > 
> > I don't really understand the problem with %gem_install, as I am using it:
> > 
> > http://git.scrit.ch/srpm/rubygem-base32/tree/SPECS/rubygem-base32.spec#n46
> > 
> > AND I think I closely follow the guidelines in the wiki
> > 
> > https://fedoraproject.org/wiki/Packaging:Ruby#.25build
> > 
> > Is the review test broken here? Can you otherwise be more specific?
> 
> The fedora-review tool is highlighting the %gem_install being missed, but i
> can see it in the spec file. And additionally there is an %install section.
> Please give me some time to find out why fedora-review is failing and if
> %install in addition to %gem_install is permissible.

Not sure why fedora-review is complaining, but the %gem_install and %install section are correct IMO. Please note that the %gem_install works in the context of %{_builddir} while the code in %install section assures that the gem content is copied from %{_builddir} into %{_buildrootdir}, where RPM can pick it up for packaging.

Comment 18 Sascha Spreitzer (Red Hat) 2017-02-20 08:00:45 UTC
(In reply to Vít Ondruch from comment #17)
> (In reply to Sascha Spreitzer from comment #13)
> > Hi Marcel
> > 
> > (In reply to Marcel Haerry from comment #9)
> > > gem_install:
> > > 
> > > I don't really understand the problem with %gem_install, as I am using it:
> > > 
> > > http://git.scrit.ch/srpm/rubygem-base32/tree/SPECS/rubygem-base32.spec#n46
> > > 
> > > AND I think I closely follow the guidelines in the wiki
> > > 
> > > https://fedoraproject.org/wiki/Packaging:Ruby#.25build
> > > 
> > > Is the review test broken here? Can you otherwise be more specific?
> > 
> > The fedora-review tool is highlighting the %gem_install being missed, but i
> > can see it in the spec file. And additionally there is an %install section.
> > Please give me some time to find out why fedora-review is failing and if
> > %install in addition to %gem_install is permissible.
> 
> Not sure why fedora-review is complaining, but the %gem_install and %install
> section are correct IMO. Please note that the %gem_install works in the
> context of %{_builddir} while the code in %install section assures that the
> gem content is copied from %{_builddir} into %{_buildrootdir}, where RPM can
> pick it up for packaging.

Agreed, opened a bug for fedora-review-plugin-ruby and cleared the review flag.
Thanks to all!

Comment 19 Gwyn Ciesla 2017-02-23 13:34:59 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-base32

Comment 20 Fedora Update System 2017-02-23 17:03:19 UTC
rubygem-base32-0.3.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7e5228d63b

Comment 21 Fedora Update System 2017-02-25 03:17:39 UTC
rubygem-base32-0.3.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7e5228d63b

Comment 22 Fedora Update System 2017-03-27 20:50:22 UTC
rubygem-base32-0.3.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.